ArtRage 5 Product PageArtRage Lite Product PageArtRage for iPad Product PageArtRage for Android Product PageArtRage  Android Oil Painter Free Product PageArtRage  Free Demos Page

Results 1 to 9 of 9

Thread: ArtRage 2.5 - Crash on opening on OSX - Updated With Fix.

  1. #1
    Join Date
    Mar 2006
    Location
    New Zealand
    Posts
    3,133

    ArtRage 2.5 - Crash on opening on OSX - Updated With Fix.

    We have had some reports from users having a problem with ArtRage 2.5 crashing when launched on OSX. So far this appears to be happening on OSX 10.4.10.

    We're working with these users currently to fix the problem and as soon as we have the solution we'll put out an updated version. In the meantime, if you are experiencing the problem please send a copy of the crash report generated when the application crashes to support@ambientdesign.com, with your OS version and Quicktime version, and we can use that information to help track it down faster.

    Sorry for the problem!
    Matt
    ArtRage UI
    Ambient Design.

  2. #2

    Crash On Opening: Possibly Due to Administrator Access?

    Don't know if this helps, but I have had the exact same problem. I think I might have narrowed down the cause though, I run OSX with an administrator account for emergencies and security reasons, and use a normal user account as my main account for everything else, Artrage crashes when I use my non admin account, but runs fine when I log in as administrator.... So im guesssing the problem has something to do with user account privelages.

    Hope this helps.

    I'm using Artrage 2.5, I dont have any older versions to try this with.

    Looking forward to a fix soon.

  3. #3
    Join Date
    Jul 2007
    Posts
    2
    No, sorry, this trick does not help here. There seems to be no difference between admin or user account. It crashes all the time at startup.

    Raed

  4. #4
    Join Date
    May 2006
    Location
    Notre Dame, IN
    Posts
    36
    10.4.10 Intel runs just fine here.

    =)

  5. #5
    Join Date
    Mar 2006
    Location
    New Zealand
    Posts
    3,133
    We're working with some users to try and get more detailed crash logs at the moment because we just can't get it to happen here. If anyone is experiencing the problem and would like to help out, you can drop me an email directly (matt@ambientdesign.com) and I can arrange a test build for you that should give us some more details.
    Matt
    ArtRage UI
    Ambient Design.

  6. #6
    Join Date
    Mar 2006
    Location
    New Zealand
    Posts
    3,133
    We've been working with users and have discovered that the crash some users are experiencing running ArtRage 2.5 on OSX relates to the OS image libraries trying to load a specific image from the ArtRage resources during ArtRage loading.

    We are still looking in to why exactly this is happening, but in the meantime we have a workaround that should allow you to run the application.

    To download the file, use this link: http://www2.ambientdesign.com/files/ar2513_resfix.zip

    To install the file, follow these instructions:

    1. Unzip the 'ar2513_resfix.zip' file by double clicking it. It should extract a file called 'system.grf'. That file is used by ArtRage in constructing its interface.

    2. Locate your ArtRage 2.5 application (the default install location is your Applications folder).

    3. Right click (or ctrl-click) the ArtRage 2.5 application and in the popup menu select 'Show Package Contents'. This opens a folder called 'ArtRage 2.5' which contains a folder called 'Contents'.

    4. Double click the 'Contents' folder and you will see a folder called 'Resources'. Drag the 'system.grf' file in to the Resources folder. You will be asked if you wish to replace the existing version, select Replace.

    You can now close the folders and ArtRage 2.5 should run for you. Note that we will be releasing this as part of an update to ArtRage in the near future. We are providing the file now so that users who are experiencing the crash can get the application working immediately.

    If you try the fix and it does not work for you, please let us know so that we can work with you to find a solution to the crash problem.

    Sorry for the inconvenience everyone!
    Matt
    ArtRage UI
    Ambient Design.

  7. #7
    Join Date
    Mar 2006
    Location
    Ambient Design
    Posts
    3,839
    More information:

    Some Mac users with the problem have reported that running a permissions repair on their system has solved the issue - we haven't confirmed this absolutely yet.

    Also if anyone isn't confident about applying the updated system.grf file to their install, you can download a new installer from the ArtRage 2.5 installer download page:
    http://www.artrage.com/artrageinstaller.html

    To reiterate: This problem was only affecting a small number of Intel Mac computers running OSX 10.4.10 with Quicktime 7.2
    If you dont have a crash immediately on starting ArtRage 2.5 then you dont need the patch. The patch doesn't give any changes in functionality, the patch is solely to address that one problem.
    There is no patch for the Windows version of ArtRage 2.5 - this problem was very specific to a small number of MacOSX 10.4.10 / Quicktime 7.2 configurations.
    AndyRage's mantra for graphics engine code:
    "Sure - how hard can it be?"

  8. #8
    Join Date
    Feb 2007
    Posts
    10
    ok.. I have windows XP home edition and my artrage 2 is crashing on me... I was able to use it once after the last update before this 2.5.15

    I just had the update where it added the stencils and new tools. Now this is the second time I'm trying to open it and it says a bunch of stuff about widgets?? lol

    The link in this thread for the fix for mac users.. is that for me too?? or am I supposed to do something different?

    I tried to send my info to get a new download link but so far I haven't gotten an email. Gonna dig around and see if I can find my install exe file somewhere and then just do the last update.

  9. #9
    Join Date
    Mar 2006
    Location
    Ambient Design
    Posts
    3,502
    If you've been to the installer page and entered your details, if you have not received an email, the number one cause for this is due to your email client incorrectly identifying it as spam. Check your junk mail folder and spam settings for a message entitled "Your ArtRage download request" from donotreply@artrage.com. Sometimes it's possible that people's internet providers are filtering these messages as spam also, while this is not common.

    This would not be related to the problem described in this thread, so please do email me at support@ambientdesign.com with the exact error message, what you're doing when you get the crash, and the steps to reproduce it, and I can work through it with you and help you out there.
    Dave
    Resident Bug-Hunter
    Ambient Design

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •