ArtRage 5 Product PageArtRage Lite Product PageArtRage for iOS Product PageArtRage for Android Product PageArtRage  Android Oil Painter Free Product PageArtRage  Free Demos Page

Results 1 to 7 of 7

Thread: [macOS] Slowly zooming or panning an empty canvas very slow. CPU utilz. 150%

  1. #1
    Join Date
    Feb 2017
    Posts
    5

    [macOS] Slowly zooming or panning an empty canvas very slow. CPU utilz. 150%

    As the title describes, opening an empty canvas (2090 x 1361) and just slowly zooming or panning is painfully slow. Decreasing the canvas size yields the same behaviour . Artrage 5 goes to over 150% utilization and stays there until I stop panning or zooming. Even just hiding the UI (with tab) a few times and I can see the CPU quickly increasing (over 50%). Any ideas what could the problem (assuming there's one) ?

    - Artrage 5.0.5 - 64 bits

    - macOS 10.12.5:
    • 5k Retina
    • RAM 40 GB 2400 MHz DDR4
    • 3.5 GHz Intel Core i5



    Note: I understand the Artrage uses the CPU instead of GPU but I tested Artrage 4 demo on a much less powerful machine (Macbook Air) and the experience there is was very smooth (even with the spike on CPU utilization).

  2. #2
    I've pulled up an activity monitor on my non-retina imac (comparable cpu, 16 gb ram, os sierra 10.12.6), and artrage takes between 15 and 25 % cpu while zooming and out, and spikes up to 50-60 % when panning (there's some slight choppiness to canvas panning in artrage, but nothing too distracting on my end.)

    artrage 4 has slightly faster canvas panning on an empty document, but cpu load can spike all the way up to 80 %

    I'm not sure what's causing this behaviour, but you can disable multi-threading from artrage preferences and see if this impacts your performance for better/for worse.

  3. #3
    Join Date
    Feb 2017
    Posts
    5
    Thanks for the reply Nekomata. Disabling multi-threading does cap the spike to around 115% (regardless of which action I take). The slow performance still remains however.

    To be clear, I don't have much of an issue if Artrage is spiking my CPU because it needs to process a bunch of stuff. My problem is that the performance is very slow in spite of that.

  4. #4
    just a thought, but can you try lowering your screen resolution in system preferences -> display tab (I think retina macs have several options, I would go with "larger text" first if this screenshot is still accurate - https://everymac.com/images/other_im...screenshot.jpg ) and see if this impacts performance for worse/for better?

    you should get a reply from AR team soon, but maybe this could make some difference meanwhile :(

  5. #5
    Join Date
    Mar 2006
    Location
    New Zealand
    Posts
    3,140
    It sounds like the input method for zoom may be generating a lot of events (eg. many 1% zoom increment events, each of which requires rendering and hence slows everything down) rather than grouping events over time to reduce the number of redraws. Could I ask what method you're using to zoom? I'm able to zoom a file of that size without an issue using the Magic Trackpad, for example.
    Matt
    ArtRage UI
    Ambient Design.

  6. #6
    Join Date
    Feb 2017
    Posts
    5
    MattRage Sorry for the late reply. I'm using a combination of CMD+SPACE+ Stylus dragging left and right. I see the same behaviour with CMD + mouse scroll "while" (magic mouse).
    Not sure if this helps but it seems that starting at zoom level 50%+ that's when things start slowing down for me.

  7. #7
    Join Date
    Feb 2017
    Posts
    5
    I forgot to add, I'm using a Wacom Intuos Pro M (not sure if this is relevant)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •