Results 1 to 9 of 9

Thread: Crashing on Launch When Starting Update

  1. #1
    Join Date
    Oct 2007
    Gallery
    View images
    Posts
    2

    Crashing on Launch When Starting Update

    The application is crashing for me and it appears to be related to the updater. It was running fine until I turned on the auto update feature and now it doesn't get past that initial small updater window.

    I have tried trashing the app and reinstalling but for some reason the preference setting for the updater doesn't get reset.

    Is there another preference file somewhere that needs to be removed or changed?

    ----
    Best regards,

    Rob

  2. #2
    Join Date
    Mar 2006
    Location
    Ambient Design
    Gallery
    View images
    Posts
    3,521
    Hi there!

    The ArtRage preferences file is called artrage.prs so if you remove that, Artrage will be set to defaults. However, it sounds like your problem relates to something to do with networking as you've ascertained, as it's crashing at that point. The default setting is to check for updates on first launch / every 2 weeks so I doubt that removal of the file will help with this.

    Can you tell me what version of operating system you're using? ( I'm assuming OS X as you mentioned trashing ArtRage ) If you're using the Leopard beta, we're aware of a problem in this respect and are currently working on a different networking method for an update.

    Could you possibly email me at support@ambientdesign.com with a crash report if not too inconvenient as well? I just want to make sure I'm on the right track and it's all useful information.

    I've uploaded a prs file to the url below which you can use you replace your current prs. This has update checking set to "off".

    http://www2.ambientdesign.com/files/ArtRage.prs

    The location that you should place the file is:

    Macintosh HD/Users/<user name>/Library/Preferences/Ambient Design/ArtRage 2
    Dave
    Resident Bug-Hunter
    Ambient Design

  3. #3
    Join Date
    Oct 2007
    Location
    California, USA
    Gallery
    View images
    Posts
    1

    Leopard Crashes

    It seems as though the crashes running under 10.5 are not limited to the updater, although the crash does manifest there early if the ArtRage software update check is enabled since it runs early after launch. Even with the update check disabled, the crashes persist. Notably, they'll occur when trying to open documents or add reference materials to a project.

    I've included the crash state below; all the crashes in ArtRage so far have been in CFStringUppercase(). For starters, it looks like an immutable string is being in to this routine, which already would seem to be a bug (the CF docs say an assertion is raised if an immutable object is passed in..)

    (gdb) run
    The program being debugged has been started already.
    Start it from the beginning? (y or n) y
    Starting program: /Applications/ArtRage 2.5.app/Contents/MacOS/ArtRage 2
    Reading symbols for shared libraries . done

    Program received signal EXC_BAD_ACCESS, Could not access memory.
    Reason: KERN_PROTECTION_FAILURE at address: 0x91c50fa9
    0x91bdbf63 in CFStringUppercase ()
    (gdb) where
    #0 0x91bdbf63 in CFStringUppercase ()
    #1 0x00117422 in ?? ()
    #2 0x001a1690 in ?? ()
    #3 0x001a2363 in ?? ()
    #4 0x001ab496 in ?? ()
    #5 0x00198f75 in ?? ()
    #6 0x0019ea38 in ?? ()
    #7 0x0006da0e in ?? ()
    #8 0x0002da66 in ?? ()
    #9 0x00030e01 in ?? ()
    #10 0x000fe45a in ?? ()
    #11 0x000f5027 in ?? ()
    #12 0x91bb4b7e in CFRunLoopRunSpecific ()
    #13 0x91bb4d38 in CFRunLoopRunInMode ()
    #14 0x952c58a4 in RunCurrentEventLoopInMode ()
    #15 0x952c56bd in ReceiveNextEventCommon ()
    #16 0x95324532 in _AcquireNextEvent ()
    #17 0x95322c8f in RunApplicationEventLoop ()
    #18 0x000f51b3 in ?? ()
    #19 0x0000836a in ?? ()
    #20 0x00008291 in ?? ()
    (gdb) info reg
    eax 0x41 65
    ecx 0x91c50fa9 -1849356375
    edx 0x61 97
    ebx 0x91bdbe54 -1849835948
    esp 0xbfffea10 0xbfffea10
    ebp 0xbfffeae8 0xbfffeae8
    esi 0x91c50fa8 -1849356376
    edi 0x1 1
    eip 0x91bdbf63 0x91bdbf63 <CFStringUppercase+291>
    eflags 0x10297 66199
    cs 0x17 23
    ss 0x1f 31
    ds 0x1f 31
    es 0x1f 31
    fs 0x0 0
    gs 0x37 55

    (gdb) p (void)CFShowStr((*(int *)($ebp + 8 )))

    Length 4
    IsEightBit 1
    HasLengthByte 0
    HasNullByte 1
    InlineContents 0
    Allocator SystemDefault
    Mutable 0
    Contents 0x91c50fa8
    $4 = void
    (gdb)

  4. #4
    Join Date
    Mar 2006
    Location
    New Zealand
    Gallery
    View images
    Posts
    3,222
    Thanks for the info. We are testing the problem currently but until we have the final release version of Leopard (next week, in theory) it's hard to know exactly what the problem is. The crash has happened in some betas, vanishing in others, and we're working on a fix currently.

    The workaround with the .prs file listed above should allow the application to run, and we hope to track down the problems and find solutions for them soon given that the ArtRage code that runs on 10.4 didn't seem to trigger a crash in the Carbon libs.
    Matt
    ArtRage UI
    Ambient Design.

  5. #5
    irishrose Guest
    Hi, I just loaded Leopard 10.5 too and am getting the same crash, the auto update screen comes up and it crashes. I guess I'll have to wait till the problem is fixed.

  6. #6
    irishrose Guest
    Hi Again,

    Just found a way around this.... turned off my airport to turn off the internet, went into the application and turned off auto updates, turned airport back on and the application works. Now to wait for a fix for the auto updates, but at least I can still use ArtRage! YAY!

  7. #7
    Join Date
    Mar 2006
    Location
    New Zealand
    Gallery
    View images
    Posts
    3,222
    The .prs file linked above (http://www2.ambientdesign.com/files/ArtRage.prs) should also fix this. If you download it and place it in the folder indicated, it has a switch that turns the auto updates check off so that you don't have to disconnect your computer to get the app running that first time.
    Matt
    ArtRage UI
    Ambient Design.

  8. #8
    irishrose Guest
    Thanks Matt... I can always check here to see if there are updates, and if not, no worries. If so, I will do what you said about downloading the .prs file. I appreciate your reply! :wink:

  9. #9
    Join Date
    Oct 2007
    Gallery
    View images
    Posts
    2

    Thanks Matt

    Been a bit busy but I wanted to let you know that this worked fine. (Both 9a559 and the 9a581 release) One note is that the preference folder did not exist prior to dropping in the prs file that you provided.

    Thanks for your help.

    ----
    Best regards,
    Rob

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •