ArtRage 5 Product PageArtRage Lite Product PageArtRage for iPad Product PageArtRage for Android Product PageArtRage  Android Oil Painter Free Product PageArtRage  Free Demos Page

Results 1 to 10 of 10

Thread: ...this pressure problem with wine

  1. #1
    Join Date
    Oct 2007
    Gallery
    View images
    Posts
    4

    ...this pressure problem with wine

    hallo guys out there.

    i just purchased a win copy of artrage. it runs pretty fine under ubuntu 7.4.
    im using a wacom intuos3 tablet (pressure doesn't work). since i read many people around having the same problems, but others do not have them,
    it would be a good idea to compare system configurations a.s.o. to finaly...
    get MY tablet's pressure sensitivity working
    ..and help others to get theirs up of course *g

    here are some system informations
    ubuntu 7.4
    wine-0.9.47
    linuxwacom 0.7.8-3

    i recognised that if i first start X and then plug in the tablet
    (this way i cant move the cursor with my pen), wacdump /dev/input/wacom
    tells me everything is correct.

    after restarting X when the tablet is already pluged in, it does its job but
    wacdump ./wacom does not show any parameters anymore.

    i dont know very much about the way linux works, so its probably ok for wacdump acting like this.


    in one other thread someone wrote that there were problems betweed synaptics touchpad and wacom. perhaps someone who got pressure working could post the xorg.conf, so we could compare.

    if theres anyone around who's linux knowlege is average he could tell me
    and others, where we should start searching for the problem.


    i hope my english is readable.
    perhaps some words are wrong...
    i'm still improving

    greets
    snoer

  2. #2
    Join Date
    May 2006
    Location
    Canada
    Gallery
    View images
    Posts
    175

    Re: ...this pressure problem with wine

    Have you installed 'wacom-tools?

    'sudo apt-get install wacom-tools'

    at the command line.

    I know my Intuos3 wouldn't work until I installed wacom-tools.

  3. #3
    Join Date
    Oct 2007
    Gallery
    View images
    Posts
    4

    wacom tools

    jap..
    wacom tools is already installed.

    when i testet ar some months ago the pressure sensitivity worked.

    it would be realy helpfull if someone who doesn't have this problem could
    attach his xorg.conf and if somone who knows more about the way linux works
    could tell where the problem could come from.

    one possibility of course is wine itself.. i think when i ran photoshop with wine
    the pressure wasn't working too..

    greetz

  4. #4
    Join Date
    Oct 2007
    Gallery
    View images
    Posts
    3
    I thought I'd relate my experience getting pressure sensitivity to work with ArtRage 2.5 and my Intuos 3 tablet on my Linux laptop. When I first installed the tablet I was running a Linux 2.6.9 kernel and Xorg 7.3/xserver-core 1.4. I was able to get the tablet working with pressure sensitivity in the GIMP but could not get the pressure sensitivity to work with wine and ArtRage (everything else worked). I decided to upgrade the kernel to 2.6.22. In the process I messed up my system and had to reinstall everything. After fixing things, I ended up back at Xorg 7.2/xserver-core 1.3. In this configuration, ArtRage worked perfectly under wine including pressure sensitivity. Not realizing what happened that got the pressure sensitivity to work, I updated all the software which got me back to Xorg 7.3/xserver-core 1.4, at which point I lost pressure sensitivity again. After reinstalling Xorg 7.2/xserver-core 1.3 I now have pressure sensitivity back. I used the same xorg.conf throughout after the initial upgrade to Linux kernel 2.6.22. My laptop has a Synaptics touchpad which may be a part of the issue here. I am not 100% certain they are the source of the problem, but if you are having trouble with pressure sensitivity, you might want to check your Xorg/xserver-core versions.

  5. #5
    Join Date
    May 2007
    Location
    Johannesburg, South Africa
    Gallery
    View images
    Posts
    96
    I'm using Ubuntu 7.10 and I'm pretty sure that uses xorg 7.2 / xserver 1.3.
    Unfortunately I don't have any pressure sensitivity in ArtRage with Wine.
    I'm sure it did work briefly in ubuntu 7.04 but somehow it disappeared.
    As always, pressure sensitivity is fine in native linux programs.

    I have a wacom graphire 3..

  6. #6
    Join Date
    Nov 2007
    Gallery
    View images
    Posts
    8
    I have the same problem with a Wacom Graphire 4, and ubuntu 7.10 + wine 0.9.50

    Since my upgrade from ubuntu 7.04 to 7.10, the pressure sensitivity isn't recognised by Wine any more, and Photoshop acts exactly like ArtRage, and uses my tablet exactly like a simple mouse.

    In another hand, this pressure sensitivity works well with standard linux applications, like Gimp. That's why I wonder if the problem would come from Wine...

    Despite my updates of Wine, till 0.9.50, the problem remains unsolved.

  7. #7
    Join Date
    Nov 2007
    Gallery
    View images
    Posts
    8
    My problem of tablet sensitivity has been solved !

    I just had to compile WINE from source.

    Here is the way to do it :
    Download the WINE source from the WineHQ website

    and choose "WINE SOURCE DOWNLOAD".

    Then uncompress the file in your home directory and execute
    tools/wineinstall

    then it's perfect for me !!!

    good luck

  8. #8
    Join Date
    May 2007
    Location
    UK
    Gallery
    View images
    Posts
    12
    Awesome!

    This works Bozo.

    I know people have had Intuos working but I never got my old Graphire working. Now I've got pressure.

    However, I did find that I had to select "Use Mouse Mode" in Artrage or it was a bit messed up.

    Incredibly, this means that Artrage under Linux Wine on a 6 year old PIV 3.0 GHz is now 100% working but actually outperforming ArtRage OSX on my dual core Mac G5 (where it can only use one 2.0 GHz core) but the performance enhancement is way more than the difference of those two CPU specs.

  9. #9
    Join Date
    May 2007
    Location
    UK
    Gallery
    View images
    Posts
    12
    I actually bought a Windows license as well as the Mac because Artrage performs so much better on Linux. Better than my Mac or with Windows on the same spec PC. However there are a few thing that cropped up.

    To install the Artrage .msi I had to use a command:

    wine msiexec /i AR2_5_winfull.msi

    Then I needed a file called GdiPlus.dll to be in system32. Obviously you can get that if you have a Windows system. It's part of what is in the WinSxS folder. I already had this entire folder in my Wine directory because ZBrush 3 needs what is in this folder but you'll have to dump that one file called GdiPlus.dll into the Wine system32. It's possible your Windows system might not have that file. I don't know because I needed to install the redistribution package of Visual C++ 2005 which puts stuff in that folder.

    By the way, I don't know if there are any ZBrush users here but that's another app that works better under Linux Wine than it does on Windows. I know this because I have two systems the same here.

    I just hope ArtRage doesn't get broken in Wine. I know the developers are not supporting Wine but it's something to think about. There is no other app in Linux to compare with ArtRage. A Native ArtRage would be especially cool.

  10. #10
    Join Date
    Apr 2006
    Location
    Winfield, Missouri, USA
    Gallery
    View images
    Posts
    20
    I have tried compiling Wine from source, and also use the default debian packages, neither one seems to work for me. Tablet works perfectly with native apps, just not anything in Wine. Running a Fujitsu wacom based tabletpc with Debian sid, 2.6.23 kernel, X.org 7.3, and the X.org wacom drivers.

    When I debug things, I get this.

    warn:wintab32:X11DRV_LoadTabletInfo did not find a valid stylus cursor with >=5 axes, returning 0 valid devices.

    I have a windows license (bought specifically for the tablet), an OSX license, and would happily buy a third license if a linux port was done.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •