Results 1 to 4 of 4

Thread: Right-click with a pen tablet

  1. #1
    Join Date
    Mar 2007
    Gallery
    View images
    Posts
    6

    Right-click with a pen tablet

    Hello,

    When I right-click using my pen tablet (an Intuos 2) to drag the canvas, or shift-right-click-drag to zoom on the canvas, a left-click seems to be recorded and it leaves a spot of paint using the current tool. It doesn't do this when I alt-right-click-drag to rotate though, which is odd.

    I think that bug wasn't there with the 2.0 versions (I'm using the latest 2.5.15). It could also be related to my upgrade to Windows Vista, which I did roughly at the same time I upgrade to 2.5... but since the rotate canvas feature doesn't have the bug, I don't really know.

    Anybody else has the same problem?

  2. #2
    Join Date
    Mar 2007
    Gallery
    View images
    Posts
    6
    Interesting... I did some testing, and there's a big mess up between right and left click in some functions. It seems to be only in artrage (I don't have those bugs in other applications like a web browser or a text editor).

    For example, Space+Left-Click is registered as a Right-Click, therefore hiding/showing the interface instead of dragging the canvas. The right click itself also hides/shows the interface, but also registers a left-click and therefore leaves a mark on the drawing. Even Space+Eraser hides/shows the interface!

    I've reset all my tablet pen settings to the default (I barely changed them anyway), and I don't have any specific settings for the ArtRage application.

    Now, I'm thinking it might be Vista's fault, as, as soon as it realized I had a tablet, it added all those TabletPC features all around (which would be super useful on a TabletPC, but not on my desktop PC...). And now I can't find how to turn those off....

  3. #3
    Join Date
    Mar 2007
    Gallery
    View images
    Posts
    6
    Ha haaa!
    (yes, I like answering to myself)

    Okay, it was Vista's fault indeed. To disable all the special tablet PC features (logon keyboard, pen flicks, snipping tool, floating input panel, etc.), go to the control panel and search for "Windows Features". There you can turn on or off Vista's features, including Tablet PC support. Reboot, and you're done.

    Now ArtRage works as intended!

  4. #4
    Join Date
    May 2006
    Location
    Canada
    Gallery
    View images
    Posts
    175
    Quote Originally Posted by lordabdul
    Ha haaa!
    (yes, I like answering to myself)

    Okay, it was Vista's fault indeed. To disable all the special tablet PC features (logon keyboard, pen flicks, snipping tool, floating input panel, etc.), go to the control panel and search for "Windows Features". There you can turn on or off Vista's features, including Tablet PC support. Reboot, and you're done.

    Now ArtRage works as intended!

    Or you can just go to the Control Panel, click on 'Programs and Features', then in the left hand column click on 'Turn windows features on or off', scroll down the list and uncheck the item 'Tablet PC Optional components'. Then reboot and the tablet features should be turned off.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •