Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Tablet PC screen rotate problem

  1. #1

    Tablet PC screen rotate problem

    I've bought the full version of ArtRage and I'm very satisfied with it, but I've bumped into a screen rotate bug on my tablet PC... I'm pretty sure it's specific to ArtRage, it doesn't seem to happen in any other app (I've tried Photoshop, Windows Journal and even Windows Paint :wink: ). It's not horribly inconvenient (restarting the application solves the problem, and I rarely need to rotate the screen while drawing), but I thought you might want to know about it.

    Whenever I rotate the screen 90 degrees, the pointer cursor's positioning remains all right (so I can access the upper menu bar etc.) but whenever I want to draw on the canvas, the brush cursor is displaced a couple of cm from the actual point where the stylus makes contact with the screen. This displacement persists even if the screen is rotated back to the original orientation. It's quite hard to explain... if I'm not being clear I can try to make a small video.

    I'm using a Thinkpad X60 Tablet with the factory WinXP install and drivers, and the latest full version of ArtRage.

  2. #2
    Join Date
    Mar 2006
    Location
    Ambient Design
    Gallery
    View images
    Posts
    3,521
    I think I've got a pretty good picture, based on what you've said there. So basically when your screens rotated the media is offset and stays offset. Here's something which might be worth a shot:

    Go to the Edit Menu -> Preferences and check "Use Mouse Mode". Quit and restart Artrage.
    Dave
    Resident Bug-Hunter
    Ambient Design

  3. #3
    Wow, yes, this fixed the problem. I would never have thought of switching it on, because the tablet is not in mouse mode (that means relative positioning, right?). I wonder if this is yet another of the driver eccentricities...

    Thanks a bunch!!

  4. #4
    Join Date
    Mar 2006
    Location
    Ambient Design
    Gallery
    View images
    Posts
    3,521
    The wording there can actually be a bit confusing. Mouse mode in ArtRage is basically just a different method of getting tablet point data, and similar to the way a lot of other graphics programs do it, so it's different from the mouse mode setting in your tablet. The other mode can be not as compatible with some configurations. I'm really glad to hear it sorted the problem out for you!
    Dave
    Resident Bug-Hunter
    Ambient Design

  5. #5
    Ah, OK. Thanks again!

  6. #6
    Join Date
    Dec 2009
    Gallery
    View images
    Posts
    18
    I'm having this same problem in ArtRage Studio 3.0.7. Except instead of it being off a couple CM it's off about 1/4 of the screen both horizontally and vertically. In this version of ArtRage I also don't see the mouse mode option.

    I'm using a HP TX2500Z tablet PC running Vista 64-bit.

  7. #7
    Join Date
    Mar 2006
    Location
    Ambient Design
    Gallery
    View images
    Posts
    3,521
    Check that you have the latest input drivers downloaded and installed from HP first, as I believe we noticed problems when using some older driver versions.

    You can find input settings for ArtRage Studio / Studio Pro in Edit -> ArtRage Preferences -> Input Device. Normally for the TX2s you would want Ink Services on, Precise tablet Mode on, Use simultaneous gestures off. You should be prompted to restart ArtRage after making changes here.

    If that doesn't help, try combinations of Ink Services and Precise Tablet Mode.

    If you still find you're having problems, check whether toggling 'Use touch input' helps the situation.

    I hope that's of some help! Let us know if you need any further assistance.
    Dave
    Resident Bug-Hunter
    Ambient Design

  8. #8
    Join Date
    Dec 2009
    Gallery
    View images
    Posts
    18
    Quote Originally Posted by DaveRage View Post
    Check that you have the latest input drivers downloaded and installed from HP first, as I believe we noticed problems when using some older driver versions.

    You can find input settings for ArtRage Studio / Studio Pro in Edit -> ArtRage Preferences -> Input Device. Normally for the TX2s you would want Ink Services on, Precise tablet Mode on, Use simultaneous gestures off. You should be prompted to restart ArtRage after making changes here.

    If that doesn't help, try combinations of Ink Services and Precise Tablet Mode.

    If you still find you're having problems, check whether toggling 'Use touch input' helps the situation.

    I hope that's of some help! Let us know if you need any further assistance.
    Ok, I already had the newest tablet drivers installed. I tried messing with all of the toggles. The only one that made any difference was turning precise tablet off. After turning it off it worked fine in every rotation except portrait2. Landscape1 being the default main rotation I use. Landscape1 -> rotate screen (portrait1) -> rotate screen (landscape2) ect. In portrait2 it works in the inverse of what I'm moving the pen at. If I draw down and then to the right, it actually draws the line at a offset up and to the left. The other problem is I had precise tablet turned on to fix a problem with wavy lines. That was discussed in this other thread. Actually it won't let me post the url to the other thread. The thread title was "AR 3 wavy not smooth lines".

  9. #9
    Join Date
    Mar 2006
    Location
    New Zealand
    Gallery
    View images
    Posts
    3,222
    It's hard to say exactly what is causing it as different machines with different configurations seem to behave in a variety of unexpected manners. One other thing to check here is that you don't have any other tablet type drivers installed than those that come specifically with your machine. If you have Wacom or Penabled type drivers installed these may interfere with the onboard drivers and cause conflicts.

    If you don't have any other drivers installed, unfortunately there's nothing else we can suggest to get your specific configuration working at this time. Checking through your ink/stylus control panels may present you with options to try (such as disabling gestures, or changing input devices, disabling touch etc.) but we can't suggest specifics.
    Matt
    ArtRage UI
    Ambient Design.

  10. #10
    Join Date
    Dec 2009
    Gallery
    View images
    Posts
    18
    To add more information about this; ArtRage 2 works perfectly rotating the screen no matter how the input settings are set.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •