Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: ArtRage is becoming nearly unusable with Mac OS Sonoma on Intel.

  1. #1
    Join Date
    Mar 2024
    Location
    South Dakota, USA
    Posts
    5

    Exclamation ArtRage is becoming nearly unusable with Mac OS Sonoma on Intel.

    Hello. I've been a happy ArtRage user for nearly three years now, but in recent months, my experiences with ArtRage Vitae have been becoming more and more frustrating, especially after upgrading my iMac to Mac OS Sonoma last fall.

    When the problems started, it was unusual pen lag when drawing on the canvas without moving the canvas for a while, with the lag going away once you moved the canvas to a new position. There is strange color darkening underneath the cursor, most visible on solid colors like green or blue. These weird cursor glitches also go away once you move the canvas.

    However, within the last few days, ARV has become more and more unstable to the point where I can't even use it for more than five minutes without a random crash happening. There is no set pattern to these crashes. A good example is the selection tool. I use the selection tool to highlight some line art I want to reposition using the "Transform Layer Contents" tool. I can select and transform initially, but when I hit the Okay button in the Transform dialog box, ARV instantly crashes. But when I tested out the same method using a blank canvas instead of my WIP, the transform tool worked fine without crashing, and it stayed that way when I used the same tool in my WIP file.

    But then other random crashes started happening. After using ARV for around five minutes or so with ample amount of drawing, the app will start crashing whenever I try to do simple tasks like selecting a new color from my palette, or hiding/showing a layer, or when attempting to use the flood fill tool.

    Whenever a crash happens, the error report always says EXEC_BAD_ACCESS (SIGSEGV), but other than that, the error report is far too complex and technical for me to figure out what exactly is causing ARV to crash with simple tool functions.

    My Mac is a 2020-year iMac, 27'', with six-core Intel Core i5 processor, Radeon Pro 5300 with 4GB VRAM, and 16GB system memory. Mac OS is Sonoma 14.4.

    For any Mac users who are also on Sonoma, are you also experiencing weird glitches, bugs, and crashes as of late, especially after updating to Sonoma 14.4? And is there an app update on the way that will address these bugs, or some way I can reset the ARV app as an additional troubleshooting step? I've already tried restarting my Mac, and shutting it down completely and powering back on cold.

  2. #2
    Join Date
    Oct 2016
    Posts
    306
    I would suggest sending a bug report to artrage team directly in your case.

    there's a fair amount of issues people were running into with sonoma, both wacom and art app related, and they all pretty much require the code to be updated; there're no under the hood magic settings in artrage that can make a lot of difference.

    I'm not sure what would the developer do in this case considering it's a combination of fairly old release and a new OS causing the problem.

  3. #3
    Join Date
    Mar 2024
    Location
    South Dakota, USA
    Posts
    5
    Quote Originally Posted by nekomata View Post
    there's a fair amount of issues people were running into with sonoma, both wacom and art app related, and they all pretty much require the code to be updated; there're no under the hood magic settings in artrage that can make a lot of difference.

    I'm not sure what would the developer do in this case considering it's a combination of fairly old release and a new OS causing the problem.
    I'll make sure to send in a bug report later today, and I'll have to use workarounds until a bug fix or update is released. I did do a full uninstall/reinstall of my Wacom tablet drivers last night before trying again. While flood fill still crashes ARV, hand coloring appears to be working fine for now, and I don't think I'll need any advanced tools to finish my new art. I am saving frequently though.

  4. #4
    Join Date
    Jan 2020
    Location
    Aotearoa/New Zealand
    Posts
    366
    Iíve been having problems too, since i upgraded to last version of Sonoma. There is new upgrade just released (14.4, i think it is), so Iíll be interested to see if that helps.

    ARV and Rebelle 7 are not playing together nicely it seems to me, and i see that Rebelle have issued an upgrade today because the changes to their brush engine have been causing problems. I was getting horrendous brush lag, which has now abated. The causes are, of course, way above my pay grade

    I too am saving very frequently

    Brett
    "You do not suffer because things are impermanent. You suffer because things are impermanent and you think they are permanent." ~ Thich Nhat Hanh

    Tech stuff: 24" iMac M1: Wacom Intuos Pro L: iPad Pro 12.9"

  5. #5
    Join Date
    Mar 2024
    Location
    South Dakota, USA
    Posts
    5
    Quote Originally Posted by Perendale View Post
    Iíve been having problems too, since i upgraded to last version of Sonoma. There is new upgrade just released (14.4, i think it is), so Iíll be interested to see if that helps.

    ARV and Rebelle 7 are not playing together nicely it seems to me, and i see that Rebelle have issued an upgrade today because the changes to their brush engine have been causing problems. I was getting horrendous brush lag, which has now abated. The causes are, of course, way above my pay grade

    I too am saving very frequently

    Brett
    It's been a bit, but I did fill out a detailed tech support request via the link above, explaining the issue and if there will be an update patch soon. I checked the update history of ARV last night in my App Store, and was shocked to see the last one was two years ago! 😮 That's a very long time to go without updates, especially for Mac users.

    As a workaround, I'll have to get out my old iMac as it has an earlier Mac OS that ARV should be able to handle. If not that, then I'm in the process of recovering my download and key for ArtRage 6, which is what I used before moving to ARV.

    It's a bit of work, but ArtRage is such an underappreciated drawing and painting app that I want to continue to support it and it has integrated well into my workflow. Hoping the dev team is busy working on a patch or the next major release as it would be very sad to see this app become abandoned.

  6. #6
    Join Date
    Mar 2024
    Location
    South Dakota, USA
    Posts
    5
    I got a reply from ArtRage support, and they said an update to fix the Mac OS Sonoma issues is being worked on, but they don't know when the release date will be. It will be a free update though.

    Until then, I'll make do with an older Mac as a temporary workaround until the new update is available.

  7. #7
    Join Date
    Oct 2016
    Posts
    306
    Quote Originally Posted by wb8979 View Post
    It's been a bit, but I did fill out a detailed tech support request via the link above, explaining the issue and if there will be an update patch soon. I checked the update history of ARV last night in my App Store, and was shocked to see the last one was two years ago! �� That's a very long time to go without updates, especially for Mac users.

    As a workaround, I'll have to get out my old iMac as it has an earlier Mac OS that ARV should be able to handle. If not that, then I'm in the process of recovering my download and key for ArtRage 6, which is what I used before moving to ARV.

    It's a bit of work, but ArtRage is such an underappreciated drawing and painting app that I want to continue to support it and it has integrated well into my workflow. Hoping the dev team is busy working on a patch or the next major release as it would be very sad to see this app become abandoned.
    hi, thanks for updating us on the coming patch. typically, unless it's something really difficult to figure out, OS patches arrive in a reasonable time span. there might be a simultaneous release for the next artrage version and the artrage vitae patch if the issue is really hard to nail down, but it is unlikely.

    you are not seeing any artrage updates past 2022 because for the most part, it just works.

    I don't think reverting to artrage 6 will make your experience better, but you will lose things like bigger brush size and performance optimizations that went into vitae, too. I would just wait until the update comes out, since you already have an older mac you can use for now.

  8. #8
    Join Date
    Jan 2020
    Location
    Aotearoa/New Zealand
    Posts
    366
    Quote Originally Posted by wb8979 View Post
    I got a reply from ArtRage support, and they said an update to fix the Mac OS Sonoma issues is being worked on, but they don't know when the release date will be. It will be a free update though.
    Thanks, thatís good to hear.
    "You do not suffer because things are impermanent. You suffer because things are impermanent and you think they are permanent." ~ Thich Nhat Hanh

    Tech stuff: 24" iMac M1: Wacom Intuos Pro L: iPad Pro 12.9"

  9. #9
    Join Date
    Feb 2024
    Posts
    2

    Vitae Crashes.

    Yes! exactly this! I have a Mac mini Sonoma 14.3.1. Vitae crashes all the time. Artrage 6 is stable but I do have those glitches you're talking about. The brush lag and then if I resize the window or move the canvas its normal for a few brush strokes them bam back to lagging again. It's making it slow to work with. The dark patches disappear when the canvas or window is resized. I also get the imprints of some of the tools at times. Highly disappointing! I upgraded to Vitae thinking it would fix it but nope Vitae crashes! Its worse!

  10. #10
    Join Date
    Oct 2016
    Posts
    306
    Quote Originally Posted by LeaS View Post
    Yes! exactly this! I have a Mac mini Sonoma 14.3.1. Vitae crashes all the time. Artrage 6 is stable but I do have those glitches you're talking about. The brush lag and then if I resize the window or move the canvas its normal for a few brush strokes them bam back to lagging again. It's making it slow to work with. The dark patches disappear when the canvas or window is resized. I also get the imprints of some of the tools at times. Highly disappointing! I upgraded to Vitae thinking it would fix it but nope Vitae crashes! Its worse!
    Hi Lea,

    if you have other painting apps, does the brush lag issue happen with them as well?

    if yes, are you on the very latest wacom driver build released specifically for sonoma?
    you might need to install it and reset all tablet preferences to default ones, because wacom drivers are quite complicated and can be buggy, particularly with the current mac os.

    for anything artrage related you're experiencing right now, unfortunately you'll have to wait for the patch. you might want to get in touch with the team (support link provided above), but it really is about waiting for the work to be finished, since you can't roll back to an older mac os on a freshly purchased mac, apple does not allow that.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •