Results 1 to 4 of 4

Thread: Color wheel doesn't show in docking mode - AR Vitae mac

  1. #1
    Join Date
    Apr 2008
    Location
    Warszawa, Poland
    Posts
    57

    Question Color wheel doesn't show in docking mode - AR Vitae mac

    Hello,

    I've just recently upgraded from AR 6 to Vitae and have a weird problem with the colour wheel.

    I use AR in Docking Mode ( Lights Out also ). In my Docking Tray, among other things, I've got the Colour Wheel ( aka Tint / Tone picker ). As I upgraded to Vitae, the Colour Wheel started - from time to time - to show up as a square:
    Name:  Screenshot 2022-12-28 at 20.51.05.png
Views: 50
Size:  59.6 KB
    In such a situation, there seems no way to make it look right again ( the way it is now it's quite awkward to use ) - the only thing I can do is to remove it from the Docking Tray, by clicking "Color Wheel" in the Tools menu. If I click "Color Wheel" again, it is back enabled as a standalone panel - and then it looks as it's supposed to be. But if I dock it again in the side panel, it gets back to square again.
    Also, when I click the Tear Off icon to undock the Color Panel - when it's in Tint / Tone mode ( and looking as a square, as I've said previously ) - AR unexpectedly quits. NOTE: this doesn't happen if the Color Panel is in another mode ( like LS/H or others ).

    This weird behaviour does not happen every time - sometimes I restart AR and everything works fine. I don't know what could possibly cause it - or make it go away. Sometimes it persists despite restarting AR, or even restarting the whole computer. One thing I can tell for sure so far - every time it happens ( and the Color Wheel is replaced by this square ), undocking the Panel as it is in Tint / Tone mode will crash AR.
    The crazy thing is that I went through this more than ten times in a row ( open AR - Panel looks as a square - undock it - crash ), and then, without any apparent reason, the Colour Wheel showed correctly and the crashing upon undocking stopped.

    I still wanted to report it as this has happened to me already several times since I upgraded.
    Maybe someone's had the same experience - and maybe there's a logical solution ( not "keep restarting over and over again until it starts working properly" )?

    Thanks in advance for any help,
    Mikołaj

    MacBook Pro - M1 chip
    MacOS Monterey 12.3.1
    AR Vitae 7.1.4 - Mac
    My illustrations:

    http://mikolajkamler.pl

  2. #2
    Join Date
    Jan 2014
    Location
    Australia
    Posts
    3,216
    Hello Mikołaj and welcome to the forum. I'm sorry I don't have any answers for you but I want to let you know your query has been seen and hopefully someone with more knowledge than I can help you. I have not seen this problem myself.

    I know it's not s solution but can you control the way the colour panel appears by using the panel menu?

    Name:  Screenshot_20221229_060011.jpg
Views: 46
Size:  88.5 KB
    June.

    Oh God of homeless things, look down
    And try to ease the way
    Of all the little weary paws
    That walk the world
    today.
    -
    Unknown.

    http://enug66.deviantart.com/gallery/

    [My setup: hp 15in laptop,11th Gen Intel Core i7-1165G7 @ 2.80GHz 2.70 GHz, 8.00 GB RAM, 24in Acer 2nd monitor, Huion Kamvas 20 Pro display tablet, Windows 11, ArtRage Vitae.
    My desktop is extended across three monitors.]

  3. #3
    Join Date
    Apr 2008
    Location
    Warszawa, Poland
    Posts
    57
    Thanks for the reply, Enug!
    Once the color panel is undocked, there is no problem with changing the mode using the panel menu, as long as the panel stays undocked. If I dock it again, though - the color wheel reverts back to square.

    On another note: I noticed that you've got a three-monitor configuration. I am curious how does AR behave in your configuration?
    I have this problem that contextual menus in AR appear not on the monitor I'm using in AR. I have a mac laptop + Cintiq + monitor configuration that works OK in other graphic apps ( like Photoshop, Krita etc ). I use AR on my Cintiq's screen, but all the contextual menus ( the ones I have in various panels ) open on my external monitor. That is, I click on a button on my Cintiq - and a menu opens on my monitor. That's quite annoying, plus the place where the menus open on my monitor's screen is mostly random, so finding them takes a while, as I have a fairly large monitor... I have described this in detail here.
    As you also have a multi-monitor configuration, I'm curious whether you've had any experiences with AR such as mine. I hope not, as this is a quite annoying behaviour...

    Mikołaj
    My illustrations:

    http://mikolajkamler.pl

  4. #4
    Join Date
    Jan 2014
    Location
    Australia
    Posts
    3,216
    Mikołaj In reply to your multi-monitor question. I have made my laptop the primary monitor. ARV opens on the laptop and I drag it over to my display tablet. As I use docking mode, my panels are locked. However, I do sometimes have a panel that is not locked and I will find it on my laptop until I drag it onto the display. I find I lose my cursor at times and it is on one of the other monitors. I use an old TV as a monitor. My setup isn't pretty but it works.


    Name:  20221201_175727.jpg
Views: 32
Size:  77.6 KB
    June.

    Oh God of homeless things, look down
    And try to ease the way
    Of all the little weary paws
    That walk the world
    today.
    -
    Unknown.

    http://enug66.deviantart.com/gallery/

    [My setup: hp 15in laptop,11th Gen Intel Core i7-1165G7 @ 2.80GHz 2.70 GHz, 8.00 GB RAM, 24in Acer 2nd monitor, Huion Kamvas 20 Pro display tablet, Windows 11, ArtRage Vitae.
    My desktop is extended across three monitors.]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •