Well this hasn't been such a good start to your ArtRage new year has it
If removing the ArtRage6.prs file hasnít worked then you could try deleting AR itself and reinstalling a fresh copy of the app. But if you do try this then you would still be wise to delete the ArtRage6.prs file again as part of this process.

But I would again strongly advise contacting Ambient Design directly at [email protected] with the full details of this problem and the steps you have tried so far to solve it. You could even point then to this forum thread to follow the story so far.
They made the app and have a far better understanding of itís dark inner workings than I
But it really sounds to me that some internal AR file has been corrupted, but apart from the ArtRage6.prs file, Iím not sure what other, user fixable, file might be the cause

As far as this being ďyour faultĒ by misusing the Warp tool then I would say no. Fear not!
With any of the tools in AR you can type in sizes over their maximums and all that happens is that they default to the permitted max size.
So donít worry itís not you who has messed up but your computer thatís dropped the ball! They will do that to us sometimes!

Sorry I havenít been more help with this but pleas do post back here once itís sorted out with the cause and solution. The info may prove useful to others in future.