Results 1 to 8 of 8

Thread: "A function call has been made to an object that is invalid". Halp!

  1. #1
    Join Date
    Jun 2017

    Unhappy "A function call has been made to an object that is invalid". Halp!

    So I received the message in the title and it keeps popping up when I try to close it. I'm not sure what I did wrong, although I was using the selection and transformation tools and trying to copy and paste images onto other layers.

    I'd rather not lose what I've done sense I've saved, so any help is appreciated. Thanks!

  2. #2
    Join Date
    Mar 2006
    New Zealand
    Sorry to hear about the problem! We've heard of a similar issue a couple of times but generally in older versions. Could you drop an email to [email protected] and let us know what OS you are using and what version of ArtRage and we can look in to it further.

  3. #3
    Join Date
    Aug 2019
    I am having the same problem, the worst part is that it won't let me check what version I am on or anything, so that avoids me from getting help, I am making an animation and I am about over half way done it when this message pops up, I want to keep all my progress, but I can't if I can't fix this issue, this has happened many times before now, and it is getting quite frustrating; I have found one way to solve this issue: restarting your laptop/device, but this causes you to lose all of your progress, so if there is a way to save my progress AND fix the message, that would be wonderful,I am very sorry that I don't know my version, but I truly hope that I can still get some help, thank you!

  4. #4
    Join Date
    May 2020

    I am having this problem as well.

    I imported a PSD and am trying to do some work with layers ( cutting and pasting). I was able to work with the file for a bit, but am now getting the "A function call has been made to an object that is invalid" error.

    Never had it before..

    What I did was import a PSD, add some layers, then cut and paste images into different layers and now it errors when I try to open the file.

  5. #5
    Join Date
    Apr 2020
    I think I'm having the same problem, but I don't see any response or answers here. I can't work, because I cannot open the programme, it hangs, I can't even quit it, then after a while it opens but without the top menu. Getting very frustrated, I'm losing income here because I can't work.

  6. #6
    Join Date
    Nov 2011
    Sorry to see you have run into a problem!
    This isnít a problem Iíve ever encountered so canít off a solution here Iím afraid
    I would recomend contacting Ambient Design directly about this here: [email protected]
    Explain your situation and give as much OS and hardware info as you can and as much detail as possible as to what you were doing when this started.
    I donít know where you are but Ambient Design are in New Zealand so there could be quite a time difference affecting response times to emails. But I have always found them very helpful.
    Good luck and hope you can get it sorted soon.
    Maker Of Replica Macoys

    Techie Stuff:
    ArtRage Vitae 7.1.4 ~ 15" Macbook Pro
    ~ macOS 10.15.7 ~ 4 Core i7 3.1GHz CPU ~ 16GB RAM ~ Wacom Intuos4 M
    My Animal Paintings In The Forum Gallery
    On Instagram

  7. #7
    Join Date
    Apr 2009
    Vienna, Austria
    I've also encountered this behaiour with moving an object I natively painted in AR on its layer. It's the latest version at the time being, 6.something. Unfortunately, I can't send the file, since I can't save it now.

    I'm on Win 10 x64, 32GB Ram, AMD 8 core, NVidia Geforce GTX 980, in case that helps.

    Edit: WILDLY speed-clicking "Close" worked. Back to normal (?). I could save the file and if required, I can send it in.
    Edit 2: I forgot to mention it looked like the top section of the entire painting was missing. After speed-clicking it was back to normal, too.
    Last edited by Corniger; 05-17-2021 at 01:08 AM.

  8. #8
    Join Date
    Jun 2021

    Exclamation Me too

    I got this error when I was trying to Import Image File to Layer, but the layer happened to be inside a layer group, when I moved to outside the layer group it worked ok. However when this error was thrown the whole program crashed. Can be replicated each time if that helps.

    Windows 10 Version 10.0.19041 Build 19041
    ArtRage version 6.1.2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts