ArtRage 5 Product PageArtRage Lite Product PageArtRage for iOS Product PageArtRage for Android Product PageArtRage  Android Oil Painter Free Product PageArtRage  Free Demos Page

Results 1 to 8 of 8

Thread: Merging Layers Taking Forever

  1. #1

    Merging Layers Taking Forever

    In AR4, lately when I've been merging layers with any kind of blend effect it takes forever. We're talking like five minutes. It does get it done eventually, but this came up out of nowhere and is sticking around thru some PC restarts and several different paintings. I'm not worried, but it is annoying. It's not slowing anything else on my PC down either.

  2. #2
    Join Date
    Dec 2013
    Location
    Reno, Nevada
    Posts
    199
    I don't know if merging layers down requires the program to use your hard drive. If you see the hard drive light constantly lighting up while it is merging then you may want to perform a chkdsk on your windows computer's hard drive. You can also check the drive from windows explorer, right click on the drive, properties, tools, check hard drive. Use the default options and see if your drive is okay. I am writing this from my iPad and I may have these steps not exactly right.

    How much free space do you have left on the drive that ArtRage is installed on? HHD? SSD? RAM available? Etc. Inquiring minds want to know and there are better professinals out there who can do a better job than I can at helping you with your issue.

  3. #3
    Quote Originally Posted by HwyStar View Post
    How much free space do you have left on the drive that ArtRage is installed on? HHD? SSD? RAM available? Etc. Inquiring minds want to know and there are better professinals out there who can do a better job than I can at helping you with your issue.
    No visible HD light so no idea on that, but it's a 3.someoddTB SSD with the better part of 3TB free and 32GB RAM. Friend built it as a beast for me to work on.

  4. #4
    Join Date
    Nov 2013
    Location
    Auckland, NZ
    Posts
    1,851
    Memory would normally be the issue here; either working with large files, or your computer running out of space. If it's neither of those things, then either something in the background is sucking up memory, or something is actually broken

    Are you seeing any difference between a mostly empty test painting with two layers at the default canvas size and a much larger more complicated image?
    Ambient Design Tech Support & Community Manager

    This is not my signature.

    Go forth and read the tutorials. Also, check out the featured artists!

  5. #5
    Quote Originally Posted by lionsilverwolf View Post
    In AR4, lately when I've been merging layers with any kind of blend effect it takes forever. We're talking like five minutes. It does get it done eventually, but this came up out of nowhere and is sticking around thru some PC restarts and several different paintings. I'm not worried, but it is annoying. It's not slowing anything else on my PC down either.
    are you merging them one by one, or merging a bunch of grouped layers together?

    I had this happening when merging a large number of layers with different opacity values (i.e. 40, 90, 30, 75, etc, and a couple completely opaque layers thrown here and there)
    I'm not sure if it's a bug or the way artrage is intended to work, but this doesn't happen when dropping layers down to a 100 % opaque layer individually. a bit more keyboard work, but it's much faster - I actually had no idea the merging actually gets done eventually,
    I just used to kill the app after a few minutes of process stuck at 80-something % complete state with no response.

  6. #6
    Quote Originally Posted by HannahRage View Post
    Memory would normally be the issue here; either working with large files, or your computer running out of space. If it's neither of those things, then either something in the background is sucking up memory, or something is actually broken

    Are you seeing any difference between a mostly empty test painting with two layers at the default canvas size and a much larger more complicated image?
    Let's see. Testing time!

    Okay I've narrowed it down to this specific instance: Grouped layers, not visible. Layers above the grouping, one with some blend mode applied. Opacity does not matter. Merging the blended layer with any layer while above a non-visible group (not interacting with the group at all). Size has an effect however it is significantly slow all the way down at 200px X 200px.

  7. #7
    Join Date
    Nov 2013
    Location
    Auckland, NZ
    Posts
    1,851
    Oh yes, I see. Thank you for tracking that down, and the very clear steps! I've passed this on and we'll see if it's something we can fix for you.
    Ambient Design Tech Support & Community Manager

    This is not my signature.

    Go forth and read the tutorials. Also, check out the featured artists!

  8. #8
    Join Date
    May 2014
    Location
    Portsmouth UK
    Posts
    631
    I have also just come across this same issue and have a .ptg just before I did the merge which means I can duplicate the problem any time if that would help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •