ArtRage 5 Product PageArtRage Lite Product PageArtRage for iOS Product PageArtRage for Android Product PageArtRage  Android Oil Painter Free Product PageArtRage  Free Demos Page

Results 1 to 2 of 2

Thread: Script playback error - dropping undo commands.

  1. #1
    Join Date
    May 2014
    Location
    Portsmouth UK
    Posts
    631

    Script playback error - dropping undo commands.

    Hi,

    Yes its me again with another script playback issue!

    This time I have not just captured my painting in real time for comparison to the playback, but also a display of the keys I pressed!, see the video below :

    https://youtu.be/XRMoFhYjZAo

    My real time recording is the bottom right (with the keys I selected displayed on the bottom right), compared to the replayed version on the top left.

    Notice that after trying to crop the painting a couple of times I then <Ctrl> Z four times (first undo is around 1:18).

    When rummaging around the .arscript file I noticed that only three <Ctrl> Z commands have been registered - you can see only three have been applied on the replay video in the top left. I added in an extra <Ctrl> Z to the script and it replayed correctly.

    I am using a Surface Pro 4, ArtRage 4.5.9 and Windows 10.

    I have noticed this issue on many occasions in the past but hadn't until now managed to catch it in a recording. I particularly have noticed it when undoing selections.

    Regards.

  2. #2
    Join Date
    Nov 2013
    Location
    Auckland, NZ
    Posts
    1,851
    Oooh, handy. Thanks for that, I've passed it onto the developers!
    Ambient Design Tech Support & Community Manager

    This is not my signature.

    Go forth and read the tutorials. Also, check out the featured artists!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •