ArtRage 5 Product PageArtRage Lite Product PageArtRage for iOS Product PageArtRage for Android Product PageArtRage  Android Oil Painter Free Product PageArtRage  Free Demos Page

Results 1 to 4 of 4

Thread: Fill removing gui on surface pro 3

  1. #1
    Join Date
    May 2014
    Location
    Portsmouth UK
    Posts
    631

    Fill removing gui on surface pro 3

    hi,

    I can produce the fault shown below in the video link pretty consistently on the surface pro 3

    https://youtu.be/gX_T83fk8sU

    when I have been using the fill tool for a little bit the fill tool line starts to remove GUI elements on the screen and I can't really do much else with ArtRage as it seems to freeze.

    Using ArtRage 4.5.7

  2. #2
    Join Date
    Mar 2006
    Location
    New Zealand
    Posts
    3,140
    That looks like an old driver v. input issue that causes hitching when tap and hold is used. Couple of things to try:

    1. Update to 4.5.9: This probably won't change it but it may have some effect.

    2. Check in your Windows Pen & Touch control panel and try turning on the press and hold - right click option if it's turned off, or turn it off if it's on. We have no idea why this changes anything but we've seen that toggle cause problems in some windows and not others, cause hitching in UI and other issues. We believe it's generally due to the way we support both Wintab & RTS and the way some drivers handle those two systems.

    3. Try toggling Wintab and RTS in the ArtRage Input Preferences panel - Make sure only one is on (technically RTS is the correct standard for Windows on a Surface, but if you've installed a third party driver to support apps that don't recognise this standard it may be interfering with the system), and try the other if that doesn't help.

    4. Back in the Windows Pen & Touch panel, try toggling Flicks off (or on, if already off) and see if that makes a difference.


    If none of that helps, let me know and we can look in to it further. We're currently looking in to completely reworking input because some of the driver and OS changes in the last couple of years have made a complete mess of the interaction between the two competing standards and the rare app that supports both can get it in the neck!
    Matt
    ArtRage UI
    Ambient Design.

  3. #3
    Join Date
    May 2014
    Location
    Portsmouth UK
    Posts
    631
    Hi,

    Here are my results after playing around :

    1. This made no difference.

    2. Turning off the press and hold meant that I couldn't move any windows around or interact with the gui.

    3. Selecting just wintab meant that I didn't get pressure sensitivity with the stylus and I
    couldn't use the fingers to pinch rotate and zoom the canvas. But it did seem to fix
    the fill issues!

    4. This made no difference.



    If none of that helps, let me know and we can look in to it further.
    We're currently looking in to completely reworking input because some of the driver and OS changes in the last couple of years have made a complete mess of the interaction between the two competing standards and the rare app that supports both can get it in the neck!

  4. #4
    Join Date
    Mar 2006
    Location
    New Zealand
    Posts
    3,140
    Okay, that's good to know. If switching to Wintab fixes that problem, but only RTS gives pressure then it sounds like there's something weird going on with your Realtime Stylus drivers.

    Do you have any third party input drivers installed? The Wacom Feel drivers that were required to provide pressure support for apps that don't do RTS are a common third party installation on the Surface Pro. Also, does RTS only solve the problem?
    Matt
    ArtRage UI
    Ambient Design.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •