ArtRage 5 Product PageArtRage Lite Product PageArtRage for iOS Product PageArtRage for Android Product PageArtRage  Android Oil Painter Free Product PageArtRage  Free Demos Page

Results 1 to 5 of 5

Thread: Opening a psd file in Artrage when the psd hasn't been created in Photoshop

  1. #1
    Join Date
    Dec 2011
    Location
    Canberra, Australia
    Posts
    124

    Opening a psd file in Artrage when the psd hasn't been created in Photoshop

    Hi,

    I might ask this on the Affinity Photo forums I guess, but I figure they're as busy as they're going to get right now, having this week launched their competitor to Photoshop.

    Like Artrage, they allow users to export and import psd files.

    So I thought, yay! I can mix and match my workflow with Artrage! Except turns out I can't... What I get when I import a psd created in Affinity to a new file into Artrage is a bunch of static. I tried merging down adjustment layers in Affinity Photo before exporting, but that wasn't it. Any ideas? Might I try saving the psd file with different specs? Or perhaps this is just one of those things that just ain't happening for now??

    BTW, using a Mac, everything has the latest updates.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Opening a PSD from Affinity.jpg 
Views:	40 
Size:	445.3 KB 
ID:	86990  

  2. #2
    Join Date
    Nov 2013
    Location
    Auckland, NZ
    Posts
    1,855
    Can you send us an example, so we can take a look? If the problem's at Affinity's end, we may not be able to do much, but we'll at least find out.
    Ambient Design Tech Support & Community Manager

    This is not my signature.

    Go forth and read the tutorials. Also, check out the featured artists!

  3. #3
    Join Date
    Nov 2011
    Posts
    937
    Yes I'm getting the same thing here too.
    Any PSD that's gone through Affinity opens in AR with just static where paint should be in the layers.
    And perhaps of interest;
    Photoshop Elements will open Affinity generated PSDs but gives a warning about unknown data before doing so.
    Pixelmator opens Affinity PSDs with no issues. So far…

    Opening/Exporting an Affinity generated PSD in an intermediate program like Pixelmator before opening with AR dose get around the problem for now but it's not ideal.
    Maker Of Replica Macoys

    Techie Stuff:
    ArtRage 5.0.5 ~ 15" Macbook Pro
    + 22" HD Monitor ~ macOS 10.12.6 ~ 4 Core i7 3.1GHz CPU ~ 16GB RAM ~ Wacom Intuos4 M and a Spyder4Pro (to keep the colours true!)

  4. #4
    Join Date
    Nov 2011
    Posts
    937
    Earlier today I posted a query about this problem on Affinity's forum.
    One of Affinity's developers replied and has a theory that it maybe something to do with the type of compression method used by their software.
    You can read the post here: https://affinity.serif.com/forum/ind...e4/#entry46586
    Hopefully this information can be of some help.
    Maker Of Replica Macoys

    Techie Stuff:
    ArtRage 5.0.5 ~ 15" Macbook Pro
    + 22" HD Monitor ~ macOS 10.12.6 ~ 4 Core i7 3.1GHz CPU ~ 16GB RAM ~ Wacom Intuos4 M and a Spyder4Pro (to keep the colours true!)

  5. #5
    Join Date
    Dec 2011
    Location
    Canberra, Australia
    Posts
    124
    Thanks for the replies. And since markw already uploaded an example to the Affinity forum and kindly linked to it, I have fewer regrets about deleting my files that didn't work...

    Is the Affinity programmer correct in his guess that 'ArtRage doesn't support ZLib compressed files - only uncompressed and RLE'?

    It's all Gobbledy Gook to me. I'll just sit tight.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •