Results 1 to 10 of 49

Thread: Surface Pen Lag/Click recognition problem

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Mar 2015

    Question Surface Pen Lag/Click recognition problem

    Hi people,

    I just bought Art Rage 4 and have updated it to 4.5.4(the latest available version). I'm using it in 64-bit mode, on a Windows 8.1, Surface Pro 3.

    My problem is the following:

    I can draw perfectly with my digitizer pen, no problems there. But as soon as I want to change tool settings, like Thinner density, pressure etc., my pen or artrage doesn't react to my pen's inputs anymore on the dialogue box. When I click on the canvas again, there appear little white circles on the spots I clicked with my pen just seconds ago.

    I can't scroll down the dialogue box with my pen, can't select anything properly(it marks sometimes, but doesn't click it, when I move sliders, the slide movement happens only when I click on the canvas. It's like it's queueing my input order from the surface pen when I'm in those dialogue boxes(brush options, presets) and executes them when I leave the dialogue area.

    I tried changing input options, precise, wintab, did try all combinations, didn't change much.

    It's annoying and slows my workflow. I saw people using the Surface Pen on the Surface Pro 3 without any problems in ArtRage, so I wonder what's up with my setup.

    Thanks for the help in advance.

    PS: Here is a vid of the problem in action. I'm using a german version.

  2. Hi,

    I have the same configuration as you do but in English; but no issue (except for palm rejection but I learned to live with it)

    I have my input device settings as "Use Realtime Stylus ON", "Wintab OFF", "Precise Tablet ON".

    I have updated to the latest NTRIG drivers (Check out their webstite).

    I hope that helps.



  3. #3
    Join Date
    Mar 2015
    Tried that, didn't work.

    Any other suggestions?

    By the way, the pen works fine with all the other apps. Photoshop, Sketchable etc. It's only those dialogue boxes of artrage that are a problem.

  4. Hi,

    None except perhaps that I keep windows up to date on their latest patches.

    ... and, do restart Artrage after making the stylus config. modifications.


    Last edited by philippecmartin; 03-05-2015 at 05:59 AM.

  5. #5
    Join Date
    Mar 2015
    Did all of those. Did restart, even the system. I'm up to date with the patches and updates as well.

    I wonder if some setting in the device manager could have caused this. Or possibly could solve this.

  6. #6
    Join Date
    Nov 2013
    Do you have any non-native drivers installed? (Such as a Wacom driver?) Also, can you send us the Pen settings in the Windows control panel? (a screenshot should be fine).

    If you want to email use directly at [email protected] we can troubleshoot a bit more easily.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts