ArtRage 5 Product PageArtRage Lite Product PageArtRage for iOS Product PageArtRage for Android Product PageArtRage  Android Oil Painter Free Product PageArtRage  Free Demos Page

Page 1 of 5 123 ... LastLast
Results 1 to 10 of 49

Thread: Surface Pen Lag/Click recognition problem

  1. #1
    Join Date
    Mar 2015
    Posts
    5

    Question Surface Pen Lag/Click recognition problem

    Hi people,

    I just bought Art Rage 4 and have updated it to 4.5.4(the latest available version). I'm using it in 64-bit mode, on a Windows 8.1, Surface Pro 3.

    My problem is the following:

    I can draw perfectly with my digitizer pen, no problems there. But as soon as I want to change tool settings, like Thinner density, pressure etc., my pen or artrage doesn't react to my pen's inputs anymore on the dialogue box. When I click on the canvas again, there appear little white circles on the spots I clicked with my pen just seconds ago.

    I can't scroll down the dialogue box with my pen, can't select anything properly(it marks sometimes, but doesn't click it, when I move sliders, the slide movement happens only when I click on the canvas. It's like it's queueing my input order from the surface pen when I'm in those dialogue boxes(brush options, presets) and executes them when I leave the dialogue area.

    I tried changing input options, precise, wintab, did try all combinations, didn't change much.

    It's annoying and slows my workflow. I saw people using the Surface Pen on the Surface Pro 3 without any problems in ArtRage, so I wonder what's up with my setup.

    Thanks for the help in advance.

    PS: Here is a vid of the problem in action. I'm using a german version. https://www.youtube.com/watch?v=9nD7hi90AQc

  2. #2
    Hi,

    I have the same configuration as you do but in English; but no issue (except for palm rejection but I learned to live with it)

    I have my input device settings as "Use Realtime Stylus ON", "Wintab OFF", "Precise Tablet ON".

    I have updated to the latest NTRIG drivers (Check out their webstite).

    I hope that helps.

    Regards,

    Philippe

  3. #3
    Join Date
    Mar 2015
    Posts
    5
    Tried that, didn't work.

    Any other suggestions?

    By the way, the pen works fine with all the other apps. Photoshop, Sketchable etc. It's only those dialogue boxes of artrage that are a problem.

  4. #4
    Hi,

    None except perhaps that I keep windows up to date on their latest patches.

    ... and, do restart Artrage after making the stylus config. modifications.

    Regards,

    Philippe
    Last edited by philippecmartin; 03-05-2015 at 05:59 AM.

  5. #5
    Join Date
    Mar 2015
    Posts
    5
    Did all of those. Did restart, even the system. I'm up to date with the patches and updates as well.

    I wonder if some setting in the device manager could have caused this. Or possibly could solve this.

  6. #6
    Join Date
    Nov 2013
    Location
    Auckland, NZ
    Posts
    1,855
    Do you have any non-native drivers installed? (Such as a Wacom driver?) Also, can you send us the Pen settings in the Windows control panel? (a screenshot should be fine).

    If you want to email use directly at support@artrage.com we can troubleshoot a bit more easily.
    Ambient Design Tech Support & Community Manager

    This is not my signature.

    Go forth and read the tutorials. Also, check out the featured artists!

  7. #7
    Join Date
    Mar 2015
    Posts
    5
    Click image for larger version. 

Name:	sampleConf.jpg 
Views:	108 
Size:	333.6 KB 
ID:	85733

    Here are the screenshots. I have no hurry, so if it's ok, I'll keep posting here.

    I don't have any non-native drivers installed for the pen, it's the default pen that arrived with the surface pro 3. The same problem occurs with the n-trig drivers installed and uninstalled.

    I have the Surface Hub installed, but I doubt that tool to be the cause of the problem.

  8. #8
    Join Date
    Nov 2013
    Location
    Auckland, NZ
    Posts
    1,855
    Hmm, okay. Nothing's jumping out.

    Can you try the following (any order)

    1. Going back to the input settings and turning OFF both Wintab and RealTime Stylus, then restarting ArtRage (I know you said you tried everything, I just want to doublecheck this one).

    This will remove pressure sensitivity, but it will help narrow down whether it's driver related in any way.


    2. Uninstalling Surface Hub, as that does affect what happens with styluses (though it shouldn't be causing this issue).


    3. Unticking "Beruehrungsfeedback - Bei Beruehrung des Bildschirms visuelles Feedback anzeigen"


    There's definitely something on your system interfering. Do you have any background stuff running?
    Ambient Design Tech Support & Community Manager

    This is not my signature.

    Go forth and read the tutorials. Also, check out the featured artists!

  9. #9
    Join Date
    Mar 2015
    Posts
    5
    Did try all of these, the issue still persists.
    I re-installed the software and tried again, still, the same thing keeps happening.

    Any other ideas? Anything I can show you that might help you solve the problem?

    PS: I have ArtRage Touch installed, too. Any chance it might interfere?(For whatever reason...)
    Last edited by Zmote; 03-07-2015 at 03:23 AM.

  10. #10
    Join Date
    Nov 2013
    Location
    Auckland, NZ
    Posts
    1,855
    Okay, we're going to need to do some fairly involved troubleshooting; can you email us at support@artrage.com?
    Ambient Design Tech Support & Community Manager

    This is not my signature.

    Go forth and read the tutorials. Also, check out the featured artists!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •