ArtRage 5 Product PageArtRage Lite Product PageArtRage for iOS Product PageArtRage for Android Product PageArtRage  Android Oil Painter Free Product PageArtRage  Free Demos Page

Results 1 to 7 of 7

Thread: Apple Magic Mouse and disappearing rulers

  1. #1
    Join Date
    Aug 2014
    Posts
    12

    Apple Magic Mouse and disappearing rulers

    Hi,

    If one scrolls with AR's round "navigator" or right-click-ctrl the rulers are switched off during scrolling and "respawn" when scrolling is over. That's the right behavior.

    But when scrolling with Apple's magic Mouse the rulers disappear and do not come back after scroll has finished.
    They come back again with rulers->visible or a shortcut.

    This is a problem, because some slight touch on the mouse surface switches off the rulers every time and that scrolling surface can not be switched off just for Artrage.
    Sometimes they disappear, when moving the rulers, because the mouse send some very small scrolling after releasing the left mouse button

    That would be no problem, if the rulers were not disabled after the scrolling with the Magic Mouse (and only with that) I could not repoduce that error with a "mechanical" mouse with a 3D-Scroll-wheel.

    Another thing that arised is that there are two different shortcuts for viewing/hiding the rulers. I think a toggle would be better, like it is one for switching the trace layer (sorry, i am using the german language version, not sure about the english term).


    Thanks,
    Donami.

  2. #2
    Join Date
    Oct 2007
    Location
    NC, USA
    Posts
    2,874

    Thumbs up Yes to the single key toggle for the show/hide

    I've made prior suggestions that a show/hide option for the rulers and stencils be a toggle, as well. It would be nice to have a single hot key toggle for them, so I'll just add my mark of approval for that suggestion again.
    Nothing is easy to the unwilling.

  3. #3
    Join Date
    Nov 2013
    Location
    Auckland, NZ
    Posts
    1,855
    This isn't normal behaviour, but could I just ask you to check one thing before we start troubleshooting?

    If you go to Edit > Set Keyboard Commands > Stencils, is there any shortcut for 'Hide All Stencils'?
    Ambient Design Tech Support & Community Manager

    This is not my signature.

    Go forth and read the tutorials. Also, check out the featured artists!

  4. #4
    Join Date
    Aug 2014
    Posts
    12

    Thumbs up Disappearing Stencils {Solved]

    Hi Hannah,

    yes. I setted one for showing all rulers and another one for hiding them.

    After deleting them in AR (and a needed restart) it works now. No disappearing rulers anymore.

    Issue closed 😊

    Thanks !

    donami
    Last edited by Donami; 02-07-2015 at 07:32 AM.

  5. #5
    Join Date
    Nov 2013
    Location
    Auckland, NZ
    Posts
    1,855
    Hurrah, I'm glad to hear it!
    Ambient Design Tech Support & Community Manager

    This is not my signature.

    Go forth and read the tutorials. Also, check out the featured artists!

  6. #6
    Join Date
    Aug 2014
    Posts
    12

    Unhappy Re-open issue

    Hi,

    so sorry, i have that issue again.
    And some cure, but first:

    How to reproduce that behaviour:

    Open AR and...
    1.Open a stencil, for example a ruler.
    2. Move the cursor outside the ruler (does not happen, when cursor is over the stencil/ruler !)
    3. Slightly wipe the magic mouse (to issue a "scroll command") in either direction. Do not click, only swype.
    4. Ruler disappears and does not come back, but can be shown again by menu/shortcut.

    This does not rely on having a shortcut for hiding or showing stencils.

    So, here is a not very good workaround:

    Disable Scrolling of Apple's magic Mouse

    How to do it:

    1. Open OSX's system preferences
    2. Open Accessibility
    3. Choose Mouse&Trackpad on the left
    4. Click "Mouse Options"
    5. Disable "Scrollig"

    The issue has gone, but scrolling is disabled system wide. As i said: not very nice.
    If scrolling is disabled, the described issue does not happen.

    The normal behavious seems to be:
    1. scroll start
    2. hide stencil
    3. scroll
    4. scroll end
    5. show stencil again

    With the magic mouse the last step is missing, with any other method it's okay.

    donami.

  7. #7
    Join Date
    Nov 2013
    Location
    Auckland, NZ
    Posts
    1,855
    Thank you for all that detail! We've been able to replicate the bug now, and are looking into it (so yes, it's definitely a bug).
    Ambient Design Tech Support & Community Manager

    This is not my signature.

    Go forth and read the tutorials. Also, check out the featured artists!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •