ArtRage 5 Product PageArtRage Lite Product PageArtRage for iOS Product PageArtRage for Android Product PageArtRage  Android Oil Painter Free Product PageArtRage  Free Demos Page

Results 1 to 3 of 3

Thread: HOWTO: Get ArtRage working under Linux

  1. #1
    Join Date
    Jan 2015
    Posts
    1

    Post HOWTO: Get ArtRage working under Linux

    Please note, that while the following steps will likely get the latest version of ArtRage installed and working on your system, no official support is provided. Also, I'm not a member of the ArtRage team, just a user ;-)

    Normal installation through Wine will unfortunately likely fail, unless you take the following steps first:

    1. Run
      Code:
      winetricks vcrun6 native_oleaut32
      on your command prompt.
    2. In the directory where you have downloaded ArtRage, run the following command:
      Code:
      wine install_artrage_4_windows.exe /extract
    3. After this, a few files, including the .msi installer, will be extracted in the same directory. Next, run the following command:
      Code:
      wine msiexec /i install_artrage_4_windows.msi
    4. This should have opened up the ArtRage installer. Normal installation should be possible after this.
    5. Unfortunately, for some reason, after installation, I noticed that ArtRage would complain about the gdiplus.dll missing. Should this happen for your installation, you should be able to install it by downloading the following redistributable from Microsoft: unfortunately I can not post a link to it, as my user account is new. You should be able to find it by searching for "Platform SDK Redistributable: GDI+" however. It should extract the gdiplus.dll file in the directory asms/10/msft/windows/gdiplus -- move it to your ~/.wine/drive_c/windows/system32 directory.
    6. I also noticed that ArtRage refused to start from the menu item created by it. You can however run it by running the following command:
      Code:
      wine "C:\Program Files (x86)\Ambient Design\ArtRage 4\ArtRage 32.exe"
    7. If you are experiencing severe performance issues, this is fixed by disabling multithreading in ArtRage. Go to the ArtRage preferences menu, find the advanced preferences, and disable multithreading there.


    I hope this is helpful to someone! And if it doesn't work, feel free to ask questions :-)

  2. #2
    Join Date
    May 2013
    Posts
    2
    Thanks this worked for me.

  3. #3
    Join Date
    May 2015
    Location
    Pasig City, Metro Manila, Philippines
    Posts
    13

    Thumbs up

    I just had to run winecfg to set Windows Version to "Windows 7" for ArtRage 4.5.4 to run in 32-bit mode. I, too, am new here, so I can't post any links. I had just posted a post on my blog about this morning's project.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •