ArtRage 5 Product PageArtRage Lite Product PageArtRage for iOS Product PageArtRage for Android Product PageArtRage  Android Oil Painter Free Product PageArtRage  Free Demos Page

Results 1 to 10 of 10

Thread: Wacom stylus challenges

  1. #1
    Join Date
    Mar 2006
    Location
    Pacific Northwest
    Posts
    2,566

    Wacom stylus challenges

    Hi Rage team, I've been trying different combinations of input device settings in AR in an effort to get the behavior I need. The trouble is, when I have wintab on I get the behavior of while using the pencil tool, I can start a stroke somewhere inside the occlusion area of a stencil and when I cross into an area that is 'open' or unblocked by the stencil, the stroke begins to draw. This is the behavior I want as that allows me to do rubbings and such without having to begin my stroke in a zero occlusion area. The problem I have is that while wintab is on, I get an offset between the cursor and the stroke (see below). Now, if I turn wintab off, the offset goes away but I then have to begin all strokes in a zero occlusion area of the stencil to get any mark.



    Name:  cursor&Wintab.jpg
Views: 214
Size:  6.2 KB



    This is in my studio machine running Win7 64-bit SP1, Cintiq 24HD, Intel Core i7-2600K CPU @ 3.40 GHz, 32.0 GB RAM.
    Be well,

    "Teach, Learn, Thrive"~DM


  2. #2
    Join Date
    Mar 2006
    Location
    Pacific Northwest
    Posts
    2,566
    Days go by. People view my post and yet... the only sound louder than my own weeping is the chirping of crickets. sigh... :-)
    Be well,

    "Teach, Learn, Thrive"~DM


  3. #3
    Join Date
    Nov 2011
    Posts
    937
    Sorry Fashmir, one of those people just looking was me!
    But I'm on a Mac and I don't have a Cintiq, so I'm not going to be of much help to you!
    Have you tried emailing Ambient Design directly? This post may have just slipped past them.
    Maker Of Replica Macoys

    Techie Stuff:
    ArtRage 5.0.5 ~ 15" Macbook Pro
    + 22" HD Monitor ~ macOS 10.12.6 ~ 4 Core i7 3.1GHz CPU ~ 16GB RAM ~ Wacom Intuos4 M and a Spyder4Pro (to keep the colours true!)

  4. #4
    Join Date
    Jan 2014
    Location
    Australia
    Posts
    2,004
    I read too but sorry, can't help.

    Someone will come to your rescue soon.
    June.

    Oh God of homeless things, look down
    And try to ease the way
    Of all the little weary paws
    That walk the world
    today.
    -
    Unknown.

    http://enug66.deviantart.com/gallery/

  5. #5
    Join Date
    Mar 2006
    Location
    New Zealand
    Posts
    3,140
    Sorry we missed this! Could you drop me an email (matt@ambientdesign.com) and we can do some research - The stencil occlusion issue and offsets that vanish when one of the tablet standards is turned off generally relates to driver issues. In the case of a Cintiq, the latest Wacom drivers will generally work best if Use Realtime Stylus is turned off and the Wacom Mapping tab's 'Use Windows Ink' option is also turned off. But if you could let me know the result of that in mail we can do some hunting.
    Matt
    ArtRage UI
    Ambient Design.

  6. #6
    Join Date
    Mar 2006
    Location
    Pacific Northwest
    Posts
    2,566
    Thanks all. I did a bunch of trial and error during which time I went partially bald from pulling my hair out. Here is what I discovered. After looking at all the Wacom and pen options I could find *anywhere* in the control panel and *NOT* finding any references what so ever to 'Windows Ink', I opened up the MOUSE properties and discovered that there were two listed. This was weird and unsettling as I have only one mouse connected to my system. One was a standard USB windows compliant listing with whatever generic driver. The other was listed as a Wacom mouse. I disabled that one, went back into ArtRage, turned off realtime stylus, turned off wintab and turned on precise tablet and IT WORKS!!! IT ALL WORKS!!!

    Thanks for the comfort your answers gave me and thank you Matt for setting me to looking deeper.

    Best to all.
    Be well,

    "Teach, Learn, Thrive"~DM


  7. #7
    Join Date
    Mar 2006
    Location
    Pacific Northwest
    Posts
    2,566
    AAAAAaaaaaaaaarrrrggggggg!!!!! Except now the stylus doesn't work in any other software and I have not pressure sensitivity and no eraser pen polarity. Back to scratch.
    Be well,

    "Teach, Learn, Thrive"~DM


  8. #8
    Join Date
    Mar 2006
    Location
    New Zealand
    Posts
    3,140
    Much as I hate to ask - Have you updated to the latest Wacom drivers? Some of their recent revisions have been getting a bit confused between Wintab and Realtime Stylus in apps that support both. Usually, turning off Wintab and turning on RTS when Use Windows Ink is on is the safest bet, but we can revert to Wintab only if needed.

    The Use Windows Ink option should be listed in the Mapping tab of the latest Wacom driver - That's what tells the driver to send RTS data instead of Wintab data and I know there have been some problems with it causing conflicts between the two systems.
    Matt
    ArtRage UI
    Ambient Design.

  9. #9
    Join Date
    Mar 2006
    Location
    Pacific Northwest
    Posts
    2,566
    Quote Originally Posted by MattRage View Post
    In the case of a Cintiq, the latest Wacom drivers will generally work best if Use Realtime Stylus is turned off and the Wacom Mapping tab's 'Use Windows Ink' option is also turned off...
    ...Seems to be the opposite of...

    Quote Originally Posted by MattRage View Post
    Usually, turning off Wintab and turning on RTS when Use Windows Ink is on is the safest bet...
    Can you clarify??? I have the latest driver, I double-checked. My silly goof was going crazy looking for a mapping tab. In my driver, 'Use Windows Ink' is in the calibrate tab, which is the mapping tab I'm guessing. :-) I've got it set to use wintab with RTS and Win-ink both off as per the your first suggestion. Seems to work so far. I have pressure, tilt, eraser and proper stencil behavior with no offset.

    Thanks Matt! If I continue to have any problems with it, I'll just email you directly.
    Be well,

    "Teach, Learn, Thrive"~DM


  10. #10
    Join Date
    Mar 2006
    Location
    New Zealand
    Posts
    3,140
    I think they must have changed the UI for the Cintiq driver, the latest driver for my Intuos has it in Mapping...

    I think I was a bit unclear before - With the Cintiq the ideal situation is Use Windows Ink is on and in ArtRage Wintab is off and RTS is on - However, for some reason we have yet to understand (we're talking to Wacom about a bunch of items right now) that sometimes just doesn't work and instead turning off use Windows Ink in the driver and RTS in ArtRage is a safer bet because it defaults to the old Wintab standard.
    Matt
    ArtRage UI
    Ambient Design.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •