ArtRage 5 Product PageArtRage Lite Product PageArtRage for iOS Product PageArtRage for Android Product PageArtRage  Android Oil Painter Free Product PageArtRage  Free Demos Page

Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Memory leak?

  1. #1
    Join Date
    Sep 2013
    Posts
    7

    Memory leak?

    Hello, everybody!

    First of all, many thanks to the product authors - I love it, despite of any issues

    I bought ArtRage 3 some time ago, upgraded to 3.5, then to 4, never regret.

    Unfortunately, I have some issues when working with huge files (it's Letter size, 600 dpi, comes to 300+ Mb with several layers). My OS is Win7, x64, 4 Gb RAM. I noticed that after some layers adding (don't know if it's really a size issue, but it looks like) and working with selections (select, then move/transform the selection) ArtRage (4.0.6, latest version) crashes and restarts with an empty default template. Have to save the work frequently (takes about 30-40 secs), a little bit annoying. Another thing, it's that my Wacom tablet input starts lagging after such an incident, have to reboot the machine in order to reset tablet to work normally. Does somebody have similar issues?

    Thank you,
    Dmitry

  2. #2
    Join Date
    Mar 2006
    Location
    New Zealand
    Posts
    3,140
    Working at that size you are going to be running very close to the memory limit of the application. It's possible that if the app crashes the system isn't clearing its temporary files from disk, this may be why you need to reboot if the system gets slow (if the disk is running low on space and the temporary files are not being deleted then that might cause problems).
    Matt
    ArtRage UI
    Ambient Design.

  3. #3
    Join Date
    Sep 2013
    Posts
    7
    Matt, thank you for the response. No, system is not running slow, mouse pointer works OK, it's just Wacom pointer is lagging. That's why I suggested mem. leak or interference between ArtRage and Wacom driver (I'm a software developer ). I've noticed the lagging even without crash, but definitely after working with a selection. I've tried to update the driver - no luck

    Quote Originally Posted by MattRage View Post
    Working at that size you are going to be running very close to the memory limit of the application. It's possible that if the app crashes the system isn't clearing its temporary files from disk, this may be why you need to reboot if the system gets slow (if the disk is running low on space and the temporary files are not being deleted then that might cause problems).

  4. #4
    Join Date
    Mar 2006
    Location
    New Zealand
    Posts
    3,140
    We're not seeing memory leaks when we run analytical builds - When you say the wacom cursor is lagging which cursor are you using? The outline cursor is rendered in to the canvas as it moves so if there's a lot going on that might slow down. The precise cursor is rendered at a slightly different point in the process. In general, slow movement inside the application is due to other processes taking up time used for cursor rendering (the app renders the cursor, not the OS in this case).
    Matt
    ArtRage UI
    Ambient Design.

  5. #5
    Join Date
    Sep 2013
    Posts
    7
    Matt, it lags in the system and all applications and, as I said, irreversible even if I close ArtRage - I have to reboot the system in order to reset to the normal behavior. Do you have some debug/logging options, probably I can try to catch the issue?

    Quote Originally Posted by MattRage View Post
    We're not seeing memory leaks when we run analytical builds - When you say the wacom cursor is lagging which cursor are you using? The outline cursor is rendered in to the canvas as it moves so if there's a lot going on that might slow down. The precise cursor is rendered at a slightly different point in the process. In general, slow movement inside the application is due to other processes taking up time used for cursor rendering (the app renders the cursor, not the OS in this case).

  6. #6
    Join Date
    Mar 2006
    Location
    New Zealand
    Posts
    3,140
    The3re aren't any debug or logging options in the application. How much disk space do you have available?
    Matt
    ArtRage UI
    Ambient Design.

  7. #7
    Join Date
    Sep 2013
    Posts
    7
    Quote Originally Posted by MattRage View Post
    The3re aren't any debug or logging options in the application. How much disk space do you have available?
    24 Gb free of 110 Gb total on C, and 5 of 50 on D, my %TEMP% and %TMP% are both set to c:\temp

  8. #8
    Join Date
    Sep 2013
    Posts
    7
    Just reproduced the issue with 57 Mb file (just 4 layers, two of them almost empty), but the page size is still Letter, 600 dpi. Went to selection, closed the selection loop (there are usually 2-3 secs of processing), then the lagging appeared. I closed ArtRage - no good. Restarted Wacom driver - it helped.

  9. #9
    Join Date
    Mar 2006
    Location
    New Zealand
    Posts
    3,140
    This might relate to the lag problems some people are seeing currently using Wacom tablets in various applications with the current driver set. Could you try a couple of things:

    1. In the Wacom control panel item under 'Mapping' for your tablet, turn off 'Use Windows Ink'. This prevents the tablet from trying to send Microsoft Realtime Stylus style events and has helped fix various tablet issues with the recent driver.

    2. If that doesn't help we've seen Wacom advising some users to do driver reinstalls. To do this, uninstall the current driver (make sure you opt to remove any user settings or profiles at this point) then reboot your system. Reinstall the driver after the reboot.

    I'm going to keep looking through the posts I found on Wacom's forum for any indication of a solution. We've seen an upswing in tablet related issues since the latest driver release and I believe this may relate to it.
    Matt
    ArtRage UI
    Ambient Design.

  10. #10
    Join Date
    Sep 2013
    Posts
    7
    Thank you, Matt, will try and post the results.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •