ArtRage 5 Product PageArtRage Lite Product PageArtRage for iOS Product PageArtRage for Android Product PageArtRage  Android Oil Painter Free Product PageArtRage  Free Demos Page

Results 1 to 6 of 6

Thread: Lasso Tool issues

  1. #1
    Join Date
    Sep 2013
    Location
    Redmond, WA
    Posts
    1

    Unhappy Lasso Tool issues

    Hey guys,

    Recently I've been having issues with the Lasso in ArtRage4.
    When I attempt to use the Freehand Lasso, and start drawing, after a set amount of time the screen flashes (aliased parts of the program turn back, like around the toolbox edges) and the selection finalizes without me clicking down.
    It didn't happen when I first downloaded the program, and since then I updated my Wacom drivers, and have the latest version of ArtRage.

    Anyone have any insight as to what might be causing this?

    Thanks!
    Jengy

  2. #2
    Join Date
    Mar 2006
    Location
    New Zealand
    Posts
    3,140
    This kind of behaviour normally indicates that the system believes the app has stopped responding to input, but it's not something I'm able to replicate here in AR4. I have a couple of questions that might help us find out what's going on:

    1. What Operating System are you using?

    2. Does this happen if you use any other tool? For example, if you paint with the airbrush in the same way you might draw with the lasso, does that cause the problem?

    3. How long do you have to draw with the lasso before it happens?

    It's possible that the driver change may have caused it but there's always a chance that there's something in the lasso that's not telling the OS the app is still processing and if that's the case we should be able to track it down.
    Matt
    ArtRage UI
    Ambient Design.

  3. #3
    Join Date
    Aug 2007
    Location
    Germany
    Posts
    1,070
    Quote Originally Posted by MattRage View Post
    This kind of behaviour normally indicates that the system believes the app has stopped responding to input, but it's not something I'm able to replicate here in AR4. I have a couple of questions that might help us find out what's going on:

    1. What Operating System are you using?

    2. Does this happen if you use any other tool? For example, if you paint with the airbrush in the same way you might draw with the lasso, does that cause the problem?

    3. How long do you have to draw with the lasso before it happens?

    It's possible that the driver change may have caused it but there's always a chance that there's something in the lasso that's not telling the OS the app is still processing and if that's the case we should be able to track it down.
    Hello Matt,

    I also get this behaviour while using the selection tool (ONLY with rectangle, ellipse and freehand - NOT with polygon, magic wand or paint area mask). other tools like airbrush or gloop pen are behaving normally.
    whenever I start a selection by clicking and moving my cursor (no matter if I use the mouse or the wacom pen), the selection starts normally, but stops after ~5 seconds. it doesn't matter if I move fast or slow, and it doesn't matter where on the screen I start. after ~5 sec of making a selection, the screen flickers, and sometimes the preset window vanishes. it looks as how you described it: "there's something in the lasso that's not telling the OS the app is still processing"

    today I installed the latest drivers for my Intuos4L, and the problem still exists.
    I am on Windows 8 Pro (64 bit), using ArtRage 4.0.4

    if you need more info, just ask. hopefully you'll be able to find the cause for this behaviour
    >>> MSIE's ArtRage Gallery <<<

    "It's a living growing mutating art sculpture painting synthesis." (quote screenpainter)

  4. #4
    Join Date
    Mar 2006
    Location
    New Zealand
    Posts
    3,140
    This might relate to the current Wacom driver's Windows Ink setting. Could you go to the driver's tablet Mapping section and turn off the Windows Ink checkbox? With that on the tablet driver may be sending right click messages from a long mouse down.
    Matt
    ArtRage UI
    Ambient Design.

  5. #5
    Join Date
    Aug 2007
    Location
    Germany
    Posts
    1,070
    yay! problem solved!
    thanks a lot, Matt! you rock
    >>> MSIE's ArtRage Gallery <<<

    "It's a living growing mutating art sculpture painting synthesis." (quote screenpainter)

  6. #6
    Join Date
    Mar 2006
    Location
    New Zealand
    Posts
    3,140
    Wow, a shot in the dark that hit! Glad to hear it's fixed
    Matt
    ArtRage UI
    Ambient Design.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •