ArtRage 5 Product PageArtRage Lite Product PageArtRage for iOS Product PageArtRage for Android Product PageArtRage  Android Oil Painter Free Product PageArtRage  Free Demos Page

Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Pen tool stokes squared off

  1. #1

    Pen tool stokes squared off

    Hi..

    When using the pen tool for fast style outlining etc and fast sketching a curve always seemed to come out a little squared off. sometimes badly at the start of a stroke.. this has been annoying me about artrage for a long time.. is there and solution? (im using a wacom, and the stroke i am making is clean and curved)

    this isnt a problem of needing 'smoothing' turned on..

    Name:  AR-problem.jpg
Views: 240
Size:  15.9 KB

  2. #2
    Join Date
    Mar 2006
    Location
    New Zealand
    Posts
    3,140
    I can't really see it happening when I try here so it could just be the stroke path registering in that manner. Could you record a script that shows the problem and send it to us at support@artrage.com and we can take a look at the pen settings and how the stroke is moving to get a better idea of what you're seeing.
    Matt
    ArtRage UI
    Ambient Design.

  3. #3
    Quote Originally Posted by MattRage View Post
    I can't really see it happening when I try here so it could just be the stroke path registering in that manner. Could you record a script that shows the problem and send it to us at support@artrage.com and we can take a look at the pen settings and how the stroke is moving to get a better idea of what you're seeing.
    Thanks.. It defiantly isn't being input like that.. ive outlined it further.. the curves are made up of distinct straight lines... these are drawn on very fast with a flick of the wrist.. there is no way i could do 3 straight lines like that.... ive had this problem since i had artrage.. on different computers.. i think it maybe just artrage cant compute a fast drawn curve properly.. (i got a fast computer btw)

    sometimes ive done my lines in other programs just for this reason..

    Name:  AR-problem2..jpg
Views: 218
Size:  19.2 KB

  4. #4
    Join Date
    Nov 2011
    Posts
    939
    Hi Matthew,
    Not sure this really helps you directly but the Pen tool has always worked fine for me in AR 3 & 4 Even when doing quick pen strokes, as you can see.
    I think maybe, and frustratingly for you, this is more likely some problem problem specific to your setup in some way rather than AR itself.
    You say its been like this on different computers, so maybe its a problem with your tablet input? Is your tablet driver up to date?
    Wish I could be of more help.
    Click image for larger version. 

Name:	Screen shot 2013-06-10 at 19.39.11.png 
Views:	100 
Size:	418.4 KB 
ID:	75875
    Maker Of Replica Macoys

    Techie Stuff:
    ArtRage 5.0.5 ~ 15" Macbook Pro
    + 22" HD Monitor ~ macOS 10.12.6 ~ 4 Core i7 3.1GHz CPU ~ 16GB RAM ~ Wacom Intuos4 M and a Spyder4Pro (to keep the colours true!)

  5. #5
    The best advice I can give you is to upgrade your setup . I have issues like that with a lot of tools when working on big files. The ink tool is one of the less resource intensive brushes in ArtRage. Smoothing does help a lot, especially on big strokes. It is a must have for sketching/drawing programs. You can use it at 5%, for your problem.

  6. #6
    Join Date
    Oct 2007
    Location
    NC, USA
    Posts
    2,874
    Not sure if it's related, but it looks like the same sort of line I get when I have the "Precise Tablet" option turned off in the ArtRage preferences. I think it may be a PC Windows only option, but if you'd like to see if it helps, go to Edit > ArtRage Preferences and select the Input Device group. You'll then find the Precise Tablet feature under the "Table Options" section. Check it off and click "OK" at the bottom of the Preference panel. ArtRage will need to be restarted before the change will apply itself.

    The image below shows lines made with the Ink Pen tool with the Precise Tablet feature off and on. I made sure to turn off the Ink Pens "Smoothing" option, so it wouldn't interfere with the results.

    Click image for larger version. 

Name:	preciseonoff.jpg 
Views:	90 
Size:	38.5 KB 
ID:	75880
    Last edited by Someonesane; 06-12-2013 at 04:12 AM.
    Nothing is easy to the unwilling.

  7. #7
    Join Date
    Mar 2006
    Location
    New Zealand
    Posts
    3,140
    Precise Tablet is definitely a possibility when this kind of thing happens, but I'd still like to see a script so we can check how the input points are looking.
    Matt
    ArtRage UI
    Ambient Design.

  8. #8
    Quote Originally Posted by Someonesane View Post
    Not sure if it's related, but it looks like the same sort of line I get when I have the "Precise Tablet" option turned off

    Click image for larger version. 

Name:	preciseonoff.jpg 
Views:	90 
Size:	38.5 KB 
ID:	75880
    yes! that fixed it..

    i should have really noticed that.. thanks.. that helps a lot...

    thanks everyone..

  9. #9
    Join Date
    Dec 2011
    Posts
    4

    massive squaring off when drawing fast cirles

    Hi, I have this same problem except on a mac and the "Squaring" is very noticeable. Working on a mac also means I do not have a "Precise Tabket" mode. I use a Wacom cintiq 12WX and can produce great fast strokes in Photoshop and Illustrator. I like the simplicity of artrage but this problem of it squaring strokes and also the ocassional case of the stroke jumping around has always detered me from using Artrage.


    Quote Originally Posted by matthewmoore3 View Post
    yes! that fixed it..

    i should have really noticed that.. thanks.. that helps a lot...

    thanks everyone..

  10. #10
    Join Date
    Dec 2011
    Posts
    4
    in your screen capture you have the "Smoothing" option set quite high. I like to have the smoothing turned to 0% to stop the stroke from altering when the computer renders it smooth , but in doing so I am left with the "Squaring" effect that alot of users have come to know in artrage. I use a mac and do not have a "Precise Tablet " mode option which seems to of helped so many. I use a Wacom cntiq 12WX and have had no probs with smooth fast strokes in other programs, I do like artrage , it is a simple and effect peice of software.

    Quote Originally Posted by markw View Post
    Hi Matthew,
    Not sure this really helps you directly but the Pen tool has always worked fine for me in AR 3 & 4 Even when doing quick pen strokes, as you can see.
    I think maybe, and frustratingly for you, this is more likely some problem problem specific to your setup in some way rather than AR itself.
    You say its been like this on different computers, so maybe its a problem with your tablet input? Is your tablet driver up to date?
    Wish I could be of more help.
    Click image for larger version. 

Name:	Screen shot 2013-06-10 at 19.39.11.png 
Views:	100 
Size:	418.4 KB 
ID:	75875

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •