ArtRage 5 Product PageArtRage Lite Product PageArtRage for iOS Product PageArtRage for Android Product PageArtRage  Android Oil Painter Free Product PageArtRage  Free Demos Page

Results 1 to 6 of 6

Thread: Cursor Is Stuck in Transform Tool

  1. #1

    Cursor Is Stuck in Transform Tool

    I was working on an illustration today and i stumbled into an unusual error.

    I duplicated a group, then clicked on "Transform Group Contents", moved and scaled the group like I wanted. I then tried to click the Ink tool, to continue drawing. The cursor remained in the form of the cross meant for the transform tool, but the preset menu showed me the Ink tool. The worst thing was that the cursor could not go on the menus, being stuck in the Transform mode, somehow. I couldn't click any menu, I tried Alt+Tab, minimize, I tried to close the program from the "X" in the corner, nu luck.

    Memory usage for AR ~1.2GB (no issues at this level)
    The only thing I could do was to right click on the taskbar icon and select close window. I was (fortunately) prompted to save my file. It saved with no issues. The alternative would be "End Process", but that loses all the work not saved. Memory usage for AR ~1.2GB (no issues at this level)

    Here's a print screen showing the panels and the cursor. The cursor couldn't go over the menus, but was responsive to movement, from mouse and tablet. Clicking did nothing for both inputs.
    Click image for larger version. 

Name:	screen.jpg 
Views:	86 
Size:	87.1 KB 
ID:	75125

    My config: Win7 64bit, Q9650 3gHz, no overclock, 8GB of RAM, Quadro FX1800, Cintiq 2100dtz as secondary display and input surface. All drivers are up to date. All system updates are in place. AR is the latest version (4.0.2).

    Thanks for listening!

    Edit: I tried to replicate the problem, on the same file, didn't work. It may be dependent on how long the file stays open and how much work is done.

    Edit 2: It happened again, but this time the file has been worked on for 30 minutes.
    Last edited by alexart; 04-22-2013 at 07:35 AM.

  2. #2
    Join Date
    Mar 2006
    Location
    Ambient Design
    Posts
    3,504
    How did you end the transform? Did you press enter on your keyboard or click outside the transform area? If you had clicked outside the transform area, depending on your transform tool settings, you may have started transforming something else which would leave you in transform mode. The preset dialog being greyed out is expected because you are in transform mode so it disables the preset panel ( which is showing your previous tool )

    A couple of things to check:

    In transform tool settings, uncheck 'select layer' before you next use this function.
    If this was checked, this may have been the problem ( you were clicking over an area which had content from another layer on it, so a new transform began )
    Also does pressing the enter key return you to normal?
    Dave
    Resident Bug-Hunter
    Ambient Design

  3. #3
    Join Date
    Mar 2012
    Posts
    3,817
    Did you have your pen upside down, set to eraser? I'm sure I have tangled with this before and felt a bit silly when I found out my mistake.

  4. #4
    "Select layer" is unchecked.
    I don't remember how I ended the transform operation. I usually press Enter, even a couple of time (this brings Workbench mode). It's possible that I selected the Ink tool directly, before pressing Enter, but this usually works, I have ended transform commands like this and it applies the transformation and goes to the tool newly selected. I tried selecting a new tool before pressing Enter, it applies the transformation and goes to the tool. No issues. I think this is the most brutal method of switching between transform and another tool.

    I did try to press Enter when the cursor got stuck, hoping it would apply the transform command and finish but it did nothing. It didn't apply the transform I was working on and it wouldn't exit the command either.

    I'll try to repeat the bug, these days. I finished my work in AR for a couple of days , though. I can't seem to replicate it on demand, it looks like something that occurs a while after the program started and I work on it a lot.

    Edit: I also tried Alt-Tab, Ctrl-Tab, Esc. Nothing would snap the program from this
    Last edited by alexart; 04-22-2013 at 01:15 PM.

  5. #5
    No, Copespeak, the pen was heading the right way. I even tried with the mouse, i turned off the tablet, turned it on again, nothing changed. Another problem was that no click worked. On my pen I have right click and middle click and they didn't do any of the commands assigned to them, the mouse was the same. I navigate with the buttons on the pen so if they aren't there, under my thumb, I immediately notice.

    Thanks for the interest, no stone left unturned

  6. #6
    Join Date
    Mar 2006
    Location
    Ambient Design
    Posts
    3,504
    If it happens again, could you email me at support@artrage.com with the following info:

    1/ What happened ( if anything ) when you initially pressed enter t0 end the transform ( any visual changes )
    2/ The size of your document and number of layers
    3/ How long you'd been working on the document that session
    4/ If possible, what you'd been doing just before you transformed
    5/ if you have a copy of the document where this happened, let me know the size of the file, I can look at getting a copy of it here for testing.
    Dave
    Resident Bug-Hunter
    Ambient Design

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •