ArtRage 5 Product PageArtRage Lite Product PageArtRage for iOS Product PageArtRage for Android Product PageArtRage  Android Oil Painter Free Product PageArtRage  Free Demos Page

Results 1 to 7 of 7

Thread: ArtRage, Wacom Cintiq, Windows 8 (one of these is not working right).

  1. #1
    Join Date
    Aug 2012
    Posts
    10

    ArtRage, Wacom Cintiq, Windows 8 (one of these is not working right).

    Hello all, I just set up my brand new comp with Windows 8, downloaded latest driver for my Wacom Cintiq 12wx and installed ArtRage Studio 3.5.5.

    One of these things is causing problems (Note: I wrote Wacom with no response, just seeing if other people have had similar problems specifically with ArtRage).

    When working in ArtRage, sometimes the Wacom driver stops working (sort of). I'll suddenly notice that one of my expresskeys isn't doing the correct command (other keys DO work correctly). I open the Wacom Tablet Properties and it says "Tablet Driver Not Found".

    Usually restarting my comp fixes this, but it happens again within a few hours, so I've been restarting my comp several times a day.

    Other times, ArtRage will freeze (very often when saving, argh) and I will be forced to shut it down via the Windows Task Manager. Because I knew of the related Wacom problems I'll double check the Wacom Tablet Properties when this happens and get the same "Tablet Driver Not Found" error.

    So I don't know if the Wacom driver is screwing up and ArtRage suffers for it, OR if ArtRage is shutting down the Wacom driver, OR if Windows 8 is doing something to one or the other.

    I have uninstalled and reinstalled the Wacom driver a few times. My next step is to uninstall ArtRage and re-download the installer file fresh to reinstall.

    If ANYONE is having similar problems, PLEASE chime in. I can't get work done without my beloved Cintiq and ArtRage.

    UPDATE: Reinstalling ArtRage did not fix the problem. My next step is to disable the Windows Tablet PC Settings as recommended on a few other websites I came across. If that works than it was neither ArtRage or Wacom.... Fingers crossed.

    UPDATE 2: Well my Windows 8 machine doesn't show "Tablet PC" options anywhere, so the numerous google results I had found that suggested turning that off won't help me.

    Other things I've tried: some people said that you open the Wacom Preferences File Utility and clear all settings. Result: extremely temporary fix, the driver is active again without the need to restart, but the next time I save in ArtRage it freezes and the driver gets lost again. This would be fine if deleting all the Preferences didn't mean that all my programmed expresskeys don't work anymore.

    Also I tried unplugging the tablet from the computer USB port before reinstalling the driver. Result: Didn't work.

    and I also tried installing the previous driver (which was the last for Win7/Vista/XP. Result: Didn't work.

    I'm at the end of my rope.

    Note: I had been using Adobe Illustrator with the cintiq earlier with no problems. That's why I'm bombarding the ArtRage forum. I will have to open up Corel Painter and see if there are similar issues (haven't used that on the new Windows 8 setup yet).
    Last edited by bfpretz; 12-19-2012 at 11:20 PM. Reason: Second Update

  2. #2
    Join Date
    Jan 2011
    Posts
    601
    My understanding is that there have been a lot of issues with Wackm drivers and Win8 so far-- that's why I've kept to Win7. Artrage does use native MS wintab pressure sensitivity though. Have you tried simply removing the Wacom driver entirely? You should still get pressure sensitivity in Artage is my understanding, but not in programs like Painter or PS. You could try dual booting into Win7- my guess is it will fix your problem. Let us know if Painter works in your current setup.
    Check out and submit to the thread on Watercolor WIPs in Artrage-- lots of good tips and conversation
    My YouTube video tutorial series- How to Paint with Watercolors in Artrage
    Try out the free
    Artrage Pen-Only Toolbar to improve your workflow and reduce clutter
    List of other good tutorials on using watercolors in Artrage
    List of good sticker sprays for watercolor effects in Artrage

    My blog- art, poetry and picture books- http://www.seamlessexpression.blogspot.com/

  3. #3
    Join Date
    Aug 2012
    Posts
    10
    I worked with Corel Painter 11 all morning with no problems. Opened up ArtRage again to see what would happen. And again when I saved, ArtRage froze, "table driver not found" all the same story.

    Unfortunately not even using the Wacom driver (and just using the MS native pressure sensitivity) wouldn't really help me get work done because I depend so much on having all my shortcuts in the expresskeys.

    Now what is "dual booting Win 7"?

    NOTE: my Dell was purchased brand new with Windows 8.

    SECOND NOTE: I created a test document at the default 1280x800 and I can work on it all day with no problems. The painting I was working on that I want to finish is 3700x5500 and has several layers and a tracing image, is over 120 MB. What this is telling me is the file is too big and that is what's causing the freezing and such, BUT I have been working on this document for a few weeks and it slowly grew as I added layers up to over 300 MB. It worked mostly fine until a few days ago when the freeze-while-saving started happening. I merged a few layers to get it down to the 120 MB thinking that would help and it didn't.

  4. #4
    Join Date
    Mar 2006
    Location
    New Zealand
    Posts
    3,140
    If you're using a Cintiq on Win8 you should have the following settings in the Input Device section of the ArtRage preferences: Use Wintab OFF, Use Realtime Stylus ON. As the Cintiq is an integrated input display device it should be using Realtime Stylus to communicate with the system.

    Looking around, I can see that a number of people are having general problems with Wacom drivers and Windows 8 at the moment, not just in specific applications. The latest drivers are most likely to give you correct operation but making sure you're using RTS rather than Wintab is also important.

    Express Key support is not part of Wintab - The Wacom drivers provide those messages directly to the active application and turning off Wintab shouldn't affect that in ArtRage, but if the problem lies in the Wacom driver on Win8 specifically then this won't help.

    The 'Tabet Driver Not Found' message is part of the Wacom system and you may need to talk to Wacom about that. It's possible that the problem in the driver is being triggered by an app requesting Wintab data, which is something Wacom would need to resolve, so it may be fixed by shifting to RTS in ArtRage but I can't say for sure as we haven't experienced these problems using a similar setup.

    If the app is crashing then it's probably a memory issue. It's unusual that it would have started suddenly however - Has anything changed on the system recently that might coincide with it? If the document has been made smaller (eg. layers merged, references and stencils closed etc.) then that should restore previous behaviour so it's possible something else is going on.
    Matt
    ArtRage UI
    Ambient Design.

  5. #5
    Join Date
    Aug 2012
    Posts
    10
    Thanks for that advice. It's actually different advice than any of the dozens of forums and message boards i've found! I will try that right now and get back on my results.

    To add more detail to my situation, I have an Intel Celerion Processor and 2GB RAM. I really want to upgrade my RAM (after Christmas if I still have money left over). So if the large file size and short RAM supply is causing the issue that would make sense. But like I said merging layers to shrink file size didn't help. Hmmm.

    Also I got ahold of Wacom and they gave me uninstall/reinstall instructions that didn't work. And thinking it might have been a recent change to my system that caused it, I did a System Restore to a week ago, but that also didn't help.

    Ok, I'll update my progress, hopefully anybody else reading the is thread can benefit from all my trials and your help.

    -Brandon
    iinkthereforeiam.blogspot.com

  6. #6
    Join Date
    Aug 2012
    Posts
    10
    Ok latest update on my progress. I changed the Wintab and Realtime Stylus options as Matt suggested. What I get now is that the program doesn't freeze on saving (YAY), but the Wacom driver still shuts down (BOO), BUT the tablet and all keys still function as programmed, so it's technically working. Even though it says it isn't.

    Basically FOR NOW, I call this a win.

    The only downside to this (other than generally knowing in the back of my head that it still needs a proper fix) is that if I decided I want to reprogram my expresskeys on my Wacom, I have to restart to get the driver working properly. But I'm pretty happy with my keys' shortcuts the way they are so like I said, I'm calling it a win.

    Thanks to both of you for helping!

  7. #7
    Join Date
    Aug 2012
    Posts
    10

    Even better! :)

    Got my Cintiq 12wx to finally work well with Windows 8 and ArtRage.

    Here's what I did and the results of thereof.

    I upgraded from 2GB to 8GB RAM in case the issues were RAM related as someone had suggested.
    RESULT: definite improvement, obviously.
    STILL A PROBLEM: slight delay on brush strokes in ArtRage, (no delay in photoshop btw). Wacom Driver still crashed upon saving.

    I used one version older of a driver (the most recent Win7 not the Win8).
    RESULT: no tablet driver crashing.
    STILL A PROBLEM: the delay on brush strokes in ArtRage.

    Searched "Control Panel" for "Pen and Touch" fiddled with those settings all day long. (a random forum I found somewhere suggested this).
    RESULT: Absolutely nothing changed with all the different options in that dialog window. Kind of wish I could set them back to default in case I screwed anything up, but there was no "set to default" option. Oh well.

    I am confident now that the delay in the brush stroke is caused by ArtRage. I was pretty sure that I had the ArtRage preferences to the best settings, but now that I've narrowed down what is and is not a problem, I went back there.... Settings in ArtRage Preferences for "Input Device" that I had were:

    Ctrl+Mousewheel = Zoom X
    Use Realtime Stylus √
    Use Wintab X
    Precise Tablet X
    Use Touch Input (Win7) X

    I already knew that Realtime Stylus and Wintab were correct from a previous response from MattRage, so I changed "Precise Tablet" to √ to see what would happen.



    RESULT: the delay in the brush stroke is gone!!!!!

    SO even though "Precise Tablet" was causing the most prevalent problem, I still feel that the Driver crashing was solved by EITHER the RAM upgrade or using the old driver or both.

    NOTE: as I was writing this and testing/playing around to make sure everything was working as I wanted before I put my words on the internet, there was a weird issue where, in any of the ArtRage pods I couldn't scroll up and down the window or change the percentage of the brush settings. I could do it with a mouse but not with the pen. I went back to the "Pen and Touch" options within "Control Panel" and I went to the settings of "Press and hold/Right-click" within the "Pen Actions" section. I had UNCHECKED "Enable press and hold for right-clicking" during all my fiddling around earlier. CHECKing this fixed the problem of clicking within the pods.

    I hope anybody coming to this because they googled the same problem that I had will find this useful. If you do, please respond saying "yeah it worked for me" cause in all my googling I always would scroll to the bottom of forum posts looking for someone to say that the above solution worked for them.

    -Brandon
    iinkthereforeiam.blogspot.com

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •