Hi all,

Mac users may be aware that the upcoming 10.8 release of Mac OS X contains a security feature called 'Gatekeeper' that by default prevents applications that are not either downloaded from the Mac App store or signed with a Developer ID certificate from launching. ArtRage Studio and Studio Pro 3.5.5 have now been released (see here) and they contain the required certificate, but as this requirement wasn't the case prior to 10.8 versions of ArtRage previous to the 3.5.5 update do not contain this certificate and as a result Gatekeeper will prevent them launching by default. Fear not though, you can still run the older version, and here's a quick guide!

Important: You can ignore this if you are using any version of Mac OS X other than 10.8 ('Mountain Lion').


Gatekeeper Settings:

Settings for Gatekeeper can be found in the 'General' tab of the 'Security & Privacy' System Preferences panel. There are three options available under 'Allow applications downloaded from:', and these can be changed if you click the 'lock' icon.

If the option is set to 'Anywhere' you can ignore the rest of this guide as your Mac will not prevent any apps launching. If the option is set to 'Mac App Store and Identified Developers' you will need to either run ArtRage 3.5.5 or follow the instructions below to authorise your version. If the option is set to Mac App Store then it's possible that even 3.5.5 won't launch as the operating system is set to only allow App Store apps.


Running ArtRage prior to 3.5.5 on OS X 10.8:

Firstly, if you copy ArtRage across to your 10.8 install from another machine you may have no problems at all. Gatekeeper is designed to prevent unknown apps downloaded from the web launching. However, if you download an ArtRage version prior to 3.5.5 from our store or from the Member Area you may find when you go to launch it that you are told it cannot be identified and cannot launch. Don't panic!

At the bottom left of the message that pops up telling you that the app cannot launch is a ? button. Click that and you will receive instructions on how to manually launch the app, which will authorise it for use despite it not containing a security certificate.

Please Note: All apps downloaded from the internet will warn you the first time they launch that they were downloaded from an external server. You can just click through this message and continue, it's not a Gatekeeper certificate warning. You only need to authorise the app following the ? instructions if the message specifically tells you that the app cannot be launched due to it being unknown.


Summary:

So, in brief:

1. If you're running ArtRage prior to 3.5.5 on Mac OS X 10.8 and you get a warning that it cannot launch due to being from an unidentified developer: Click the ? button and follow the instructions to manually authorise it.

2. Download ArtRage 3.5.5 if you can from our Member Area.