ArtRage 5 Product PageArtRage Lite Product PageArtRage for iOS Product PageArtRage for Android Product PageArtRage  Android Oil Painter Free Product PageArtRage  Free Demos Page

Results 1 to 2 of 2

Thread: Compatibility

  1. #1
    Join Date
    Jan 2012
    Posts
    1

    Compatibility

    I have Art Rage 2.5. It worked on my old Mac with OS 10.4. It does not work on my newer Mac with OS 10.6. What are my options?

  2. #2
    Join Date
    Mar 2006
    Location
    Ambient Design
    Posts
    3,504
    Is it crashing when you launch ArtRage? If this is the case, you are likely using an old version of ArtRage which was released before OS X 10.6 and is not compatible. Download the latest version ( ArtRage 2.6 ) from the Member Area at http://members.artrage.com

    1/ Click ‘create account’ and follow the instructions ( if you haven't done so before )

    2/ Log in, then click on 'My Products'

    3/ Click 'Register New Product' ( If you haven't done so before ) then select your version of ArtRage , enter your serial number and click the 'register' button to register your software

    You should now see your serial number listed on the 'My Products' page and you can click 'download' to download any of the latest versions ( Windows or OS X ).

    if you have any questions or problems, feel free to email me the details and support@artrage.com and I can help you directly.
    Dave
    Resident Bug-Hunter
    Ambient Design

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •