In case somebody has trouble with performance of artrage:
I had problems with the performance of artrage on an acer netbook, as almost every time I moved the cursor around on the screen artrage brought up a message "please wait", and it calculated for about 2 seconds or more. Every time I finished a line the same happened.
After I disabled the automatic translation program "lingoes" which was running in the background (causing no problems with other programs) the problem was gone.