ArtRage 5 Product PageArtRage Lite Product PageArtRage for iOS Product PageArtRage for Android Product PageArtRage  Android Oil Painter Free Product PageArtRage  Free Demos Page

Results 1 to 3 of 3

Thread: Strange playback issue.

  1. #1
    Join Date
    Feb 2010
    Location
    Dallas, TX
    Posts
    91

    Strange playback issue.

    http://dl.dropbox.com/u/2904948/Sketches/Conan.arscript

    Recorded on ArtRage iPad. Right around 92-94% undo either stops working or stopped recording. Then soon after the undo problem, the sketch layer duplicates into the inking layer.

    It happens while drawing the girl's arm with pen. It's a little hard to see since the iPad isn't recording layer opacity changes just yet.

    I recorded it with ArtRage iPad 1.2 and played it back on ArtRage 3.5.1. Accelerated playback takes about 3 minutes.

    Is there a way to fix this script?

    BTW, I commented out CanvasXform and SetClearCanvas, but the script was funny before the edit.

  2. #2
    Join Date
    Mar 2006
    Location
    New Zealand
    Posts
    3,140
    Thanks for posting the script, we're taking a look at it and see if we can find out what happened.
    Matt
    ArtRage UI
    Ambient Design.

  3. #3
    Join Date
    Feb 2010
    Location
    Dallas, TX
    Posts
    91
    I figured out the problem. Swipe to undo doesn't get recorded. I mostly used the undo button on the toolbar. At one point I accidentally hid the interface so I just went with it and started swiping to undo.

    Here is the final PTG of my drawing if it helps.
    http://dl.dropbox.com/u/2904948/Sketches/Conan_005.ptg

    For the undo bug check this out:

    If you open this PTG file you'll only see the word "done" written out.
    http://dl.dropbox.com/u/2904948/Sket...ndo%20test.ptg

    But if you playback this script you'll see undo spelled out in cursive. Because the swipe to undo didn't get recorded.
    http://dl.dropbox.com/u/2904948/Sket...0test.arscript

    Glad I can help. I hope I'm not causing too many problems for you guys. I know I can fix my script now if I find the spots to put the undo command. I mostly used the toolbar button so it won't be too bad.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •