ArtRage 5 Product PageArtRage Lite Product PageArtRage for iPad Product PageArtRage for Android Product PageArtRage  Android Oil Painter Free Product PageArtRage  Free Demos Page

Results 1 to 4 of 4

Thread: MSI deployment thru GPOs

  1. #1
    Join Date
    Aug 2010
    Posts
    2

    MSI deployment thru GPOs

    Hi,
    I extracted the .msi file and the .cab file from the ArtRage Starter Edition .exe file with the /extract command line.

    I want to deploy the msi to our classrooms in a few schools, but when I try, I get an error "This action is only valid for already installed product". Can someone tell me how to create an mst file that will enable me to use the msi and deploy it thru Mircrosoft AD GPOs ?

    Our users have only user rights, so it cannot be done by script. We don't have SMS or anything like that... we use only GPOs.

    Thanks,
    Alexandre Chevrier

  2. #2
    Join Date
    Mar 2006
    Location
    New Zealand
    Posts
    3,137
    Unfortunately we're not familiar with the specific system but it sounds like there is a problem with the Windows Installer handling the file you have extracted, or possibly failing to install an item that is then being registered to the OS. The ArtRage installer is a pretty simple system, the only system level things it installs are the thumbnail viewers, and the only registry items it installs are the entries for file association, I'm not sure why you would be seeing this problem unless there was an issue with the thumbnail DLLs. Does the normall installer work on the same system?
    Matt
    ArtRage UI
    Ambient Design.

  3. #3
    Join Date
    Aug 2010
    Posts
    2
    Installer and extracted msi both install correctly if done localy. It's when I try to deploy the application thru GPO that the msi won't install... as if I need to be logged on to launch the msi.

  4. #4
    Join Date
    Mar 2006
    Location
    New Zealand
    Posts
    3,137
    As it appears to be an external system, and one we don't have any experience with, we're unable to provide any direct support for it. I did find an article on GPO distribution on the site of the company that produces the installation system we use however, this may be useful: http://www.advancedinstaller.com/use...orial-gpo.html

    If that doesn't help there's unfortunately nothing I can suggest.
    Matt
    ArtRage UI
    Ambient Design.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •