ArtRage 5 Product PageArtRage Lite Product PageArtRage for iPad Product PageArtRage for Android Product PageArtRage  Android Oil Painter Free Product PageArtRage  Free Demos Page

Results 1 to 3 of 3

Thread: Can't install 3.0.6 update and original install removed

  1. #1
    Join Date
    Dec 2009
    Posts
    9

    Can't install 3.0.6 update and original install removed

    Hi,

    I'm using Windows Vista Ultimate under an account with administrator rights. I had installed the original ArtRage Studio Pro, then the 3.0.5 upgrade over that, when it came out. Now, with 3.0.6, I attempted to do the same. I ran the installer and partway through, it stopped with the error shown in the attachment. The first time I got this message I chose "Retry" and finally "Cancel" when that didn't work. The cancel backed out of the install, but it seems it removed the previous install not just the aborted update.

    Trying to install again, I keep getting the message about ArtRage Support.url not being able to be updated. I can't proceed further in the install and canceling removes everything. There is nothing to uninstall from the "Add and Remove Programs" control panel and no files under "Program Files" are left.

    For your information, initially I ran the updater .exe just by double clicking it. On a subsequent attempt I tried to execute it by choosing "Run as administrator" thinking that there might be some sort of problem wrt file writing permissions, but to no avail.

    What is your advice on this? I'm left without a usable application.

    Thanks,
    Adrian Sampaleanu
    Attached Images Attached Images  

  2. #2
    Join Date
    Mar 2006
    Location
    New Zealand
    Posts
    3,133
    It sounds like there was a problem with the uninstallation of a previous install. If you remove ArtRage from your system by uninstalling, then check your Start Menu do you still have any entries? If so, there may be a permissions problem removing the old version which is causing errors when the new installer tries to write files.

    If there are any files left in the start menu after uninstall, check their properties by right clicking and make sure that they are not listed as Read Only. If they are, turn that off and try again. If that fails, manually remove them.

    If there are no files left after uninstall then your Windows Installer probably has corrupted entries and you will need to clean out any references that have problems. Microsoft have a utility for cleaning the installer in case of problems such as this, you can find a link to download it here:

    http://support.microsoft.com/kb/290301

    That may be useful in cleaning up the installer references after the uninstall. You should then be able to install the new version. The old installers didn't set any of their files to be permanent or read only, so something must have happened to confuse the system (especially as that error relates to ini files, and there are no ini files installed by ArtRage).
    Matt
    ArtRage UI
    Ambient Design.

  3. #3
    Join Date
    Dec 2009
    Posts
    9
    It seems that somehow the .url files were truncated to 0 length during the attempted installation and Explorer ended up holding on to the file handles so that they couldn't be deleted or overwritten. A log-off/log-in cleared the locks and allowed proper installation.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •