ArtRage 5 Product PageArtRage Lite Product PageArtRage for iOS Product PageArtRage for Android Product PageArtRage  Android Oil Painter Free Product PageArtRage  Free Demos Page

Results 1 to 6 of 6

Thread: Problems on osx importing files from inside "packages"

  1. #1
    Join Date
    Nov 2008
    Location
    Melbourne Australia
    Posts
    14

    Problems on osx importing files from inside "packages"

    I've noticed artrage now supports dragging files into it's window (then gives an option to import/create tracing image/etc). This is great!

    I've also noticed that you can't drag files in from iPhoto. This should work just like normal, however, iPhoto files are stored inside the "iPhoto library" document. Effectively these files are actually directories like any other, but disguised as single files to simplify the user dealing with them. In the mac vernacular they're called "packages" and can be browsed by right-clicking on the file and choosing "view package contents".

    Applications which understand these collections can browse them like any normal directory. It seems that artrage is getting confused by the package and giving up. Browsing the package in finder and dragging the file directly from the embedded folder also fails.

    It would be great if artrage understood packages, and I believe it should not be hard to implement. This would allow us to drag assets directly from iPhoto or other package aware applications (curio, i think evernote and circus ponies notebook, etc).

    Thanks for the great work on AR3 by the way.

  2. #2
    Quote Originally Posted by Pavig Lok View Post
    I've also noticed that you can't drag files in from iPhoto. This should work
    That's working for me, I can drag photos from iphoto window to the AR window and import as a reference or other choice.

    But the file selector doesn't allow to browse into iphoto library.
    AR 3.0.8/MacBookPro 2.4Ghz 4Gb RAM/NVidia 8600M GT 256Mb/MacOS 10.6.4/Wacom Bamboo

  3. #3
    Join Date
    Feb 2010
    Location
    NSW mid-north coast, Australia
    Posts
    2
    Quote Originally Posted by groumpf View Post
    That's working for me, I can drag photos from iphoto window to the AR window and import as a reference or other choice.

    But the file selector doesn't allow to browse into iphoto library.
    Hello,
    I trialled 2.5 a couple of weeks ago and purchased it to try all features. I liked it so much I then purchased Studio immediately. I don’t get much time to use it but recently I found the following:

    Cannot open saved .ptg files from sub folders within my ArtRage folder. Either the canvas remains blank or get the message: “Generic Failure. ArtRage encountered an error trying to load the selected file, the file may be damaged or an unsupported format.”
    Sometimes the cursor disappears and have to click elsewhere? (stick the tail on the donkey) to get it back.

    Also cannot import files from specific folders - PhotoShop saves, Photographs saves, etc. Get the same message; losing cursor at times.

    However, If I create a folder on the desktop (I name it: ArtRage Files) and drag files to it they will open as required. Also, drag & drop will work from the desktop folder into ArtRage. If dragging say a Photoshop file, a panel will open up asking what you want to do with the file.

    This maybe related to the first post re. “packages”.

    Is this a glitch with 10.6.2?
    There maybe other hiccups with ArtRage & 10.6.2 which I have not experienced as yet.

    Perhaps the forthcoming update can attend to these problems?
    Last edited by kendrew; 03-10-2010 at 05:54 PM.

  4. #4
    Join Date
    Mar 2006
    Location
    New Zealand
    Posts
    3,141
    Do the subfolders have '/' in the name? At the moment there will be a problem loading files if the path contains / characters inside folder names. If the folders or paths don't have / in them, could you run a disk permissions check and repair and see if that works.

    Loading from packages from inside ArtRage probably won't work, the file dialog is set not to browse in to application bundles as if they were folders, but drag and drop should (barring / characters, as noted above).
    Matt
    ArtRage UI
    Ambient Design.

  5. #5
    Join Date
    Feb 2010
    Location
    NSW mid-north coast, Australia
    Posts
    2
    Quote Originally Posted by MattRage View Post
    Do the subfolders have '/' in the name? At the moment there will be a problem loading files if the path contains / characters inside folder names. If the folders or paths don't have / in them, could you run a disk permissions check and repair and see if that works.

    Loading from packages from inside ArtRage probably won't work, the file dialog is set not to browse in to application bundles as if they were folders, but drag and drop should (barring / characters, as noted above).
    Thanks for your reply.
    No, there are no "/" in the names.
    I ran a permissions check before my first post but behaviour continued.
    However, after you said drag and drop should work, I did some more experimentation and found that after performing drag & drop (from my ArtRage desktop folder), into a new blank canvas the “cursor” disappears - and the “camera shutter sound” can be heard but the canvas remains blank. A second click brings up the option box (which works) and cursors are restored.
    Using the “Import Image File” function from the menu bar, the file opens normally.

    But, when attempting a drag & drop from “package” folders the cursor disappears without shutter sound, the canvas is blank and the second click restores the cursor but no file is opened.
    Using the “Import Image File” function, the error message is revealed.

    Another observation - from the desktop folder:
    Drag & Drop .ptg files onto the ArtRage Icon works fine.
    Drag & Drop other files formats onto the AR Icon do not open unless say, a .ptg is converted to another format say .psd - then it opens.
    Drag & Drop from “package” folders onto the AR Icon does not work.

    Hope this info is useful - sorry for any confusing detail.

  6. #6
    Join Date
    Mar 2006
    Location
    New Zealand
    Posts
    3,141
    As we're handling this in email I'll post an update when we have narrowed down the behaviour so that any users with similar problems can see the solution or understand the situation.
    Matt
    ArtRage UI
    Ambient Design.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •