ArtRage 5 Product PageArtRage Lite Product PageArtRage for iOS Product PageArtRage for Android Product PageArtRage  Android Oil Painter Free Product PageArtRage  Free Demos Page

Results 1 to 7 of 7

Thread: AR 3.0.4 Studio Pro, OSX 10.5.7 PPC, Layers Palette Bug

  1. #1

    AR 3.0.4 Studio Pro, OSX 10.5.7 PPC, Layers Palette Bug

    I'll attempt to confirm or deny this at home on my PC tonight, but here at work when I create a new layer the first click off it in the layers palette, AR3 drops me back to the base layer. After that, I can no longer select the higher layer. I can re-organize them, bringing that layer to the bottom, but I can't paint on anything but the base layer after that first click.

    Steps to reproduce:

    1. Create a new document.
    2. Open the Layers Pod.
    3. Create a new layer.
    4. Click back to the base layer.
    5. Try to click back to your new layer.

    I've placed the platform and specs in the title header but for the sake of being thorough, I've attached a PDF of the system information profiler's dump (minus the applications stuff, just too much of that.)
    Attached Files Attached Files

  2. #2
    Join Date
    Mar 2006
    Location
    Ambient Design
    Posts
    3,839
    There does appear to be a bug with the layers palette update on PPC Macs. We're looking into it and we will release an update to ArtRage to fix this (and a couple of other issues) as soon as we can.
    AndyRage's mantra for graphics engine code:
    "Sure - how hard can it be?"

  3. #3
    Appreciate the quick confirmation, Andy. Thanks.

  4. #4
    Join Date
    Mar 2006
    Location
    Sweden
    Posts
    79
    I have the same layer palette behaviour, using G5 ppc 2ghz dual, osx 10.5.8

  5. #5
    Join Date
    Mar 2006
    Location
    Ambient Design
    Posts
    3,839
    Okay, I think we have this one nailed - there will be a fix for this in the update release, which should be before xmas.
    It was an issue with PPC data being differerent 'endian' than Intel data. A pointer to a variable was being seen as the wrong data type, so all the interesting stuff was being dropped off the end on PPC, but was still there on Intel.
    Easy to fix, but it did take me three computers (a PC, an Intel Mac, and a PPC Mac) working together to find it.
    AndyRage's mantra for graphics engine code:
    "Sure - how hard can it be?"

  6. #6
    Join Date
    Mar 2006
    Location
    Sweden
    Posts
    79
    Quote Originally Posted by AndyRage View Post
    Okay, I think we have this one nailed - there will be a fix for this in the update release, which should be before xmas.
    It was an issue with PPC data being differerent 'endian' than Intel data. A pointer to a variable was being seen as the wrong data type, so all the interesting stuff was being dropped off the end on PPC, but was still there on Intel.
    Easy to fix, but it did take me three computers (a PC, an Intel Mac, and a PPC Mac) working together to find it.
    Good work Andy! Great to have an update before xmas!

  7. #7
    Join Date
    Dec 2009
    Location
    Barcelona, Spain
    Posts
    97
    Great! Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •