ArtRage 5 Product PageArtRage Lite Product PageArtRage for iPad Product PageArtRage for Android Product PageArtRage  Android Oil Painter Free Product PageArtRage  Free Demos Page

Results 1 to 8 of 8

Thread: AR3 Pointer bug

  1. #1
    Join Date
    Oct 2007
    Location
    UK
    Posts
    12

    AR3 Pointer bug

    Hi, I've only been playing with AR3 a few minutes so far (and very good it is too, everything I wanted added to 2.5 and then some), but I've tripped over a tiny bug.

    If I paint with my tablet, minimize the ArtRage window to do something else on windows, then maximize the window now using a mouse instead of the tablet, the pointer disappears and wont interact with the canvas in any way... until I swap back to my tablets pen.

    I'm guessing it's getting confused over what input device it's supposed to be using. Not a major issue, but I thought I'd bring it to your attention.

  2. #2
    Join Date
    Mar 2006
    Location
    Ambient Design
    Posts
    3,839
    Are you using Windows or Mac OSX? What version of the operating system?
    Are the cursors you're using the circular outline cursors, or the tool or precise cross-hair cursors?
    AndyRage's mantra for graphics engine code:
    "Sure - how hard can it be?"

  3. #3
    Join Date
    Oct 2007
    Location
    UK
    Posts
    12
    Windows Xp Pro SP3, with an Intuos 2 tablet.

    The pointer was set to outline, but I just tested for you with the others in the same way, tool cursor shows and moves around but does not paint, Precise cursor also shows up but does not paint after changing to the mouse. But everything works again after returning to the tablet pen.

    [edit] Also, with the outline cursor, it will show up over tool palettes, but not over the canvas.
    Last edited by banjaxedmdt; 12-16-2009 at 09:40 AM.

  4. #4
    Join Date
    Mar 2006
    Location
    Ambient Design
    Posts
    3,839
    It's possible downloading the latest Wacom tablet drivers will help. It sounds as though the tablet properties aren't quite being reset correctly when switching applications.
    You could also try changing the 'precise tablet mode' and 'ink services' settings in the ArtRage preferences panel.
    AndyRage's mantra for graphics engine code:
    "Sure - how hard can it be?"

  5. #5
    Join Date
    Oct 2007
    Location
    UK
    Posts
    12
    Turns out I don't even need to minimize AR for the problem to occur, just changing focus to a different app or windows desktop and swapping from tablet to mouse the refocussing on AR will do the same thing.

    [edit] Already using the latest drivers.

  6. #6
    Join Date
    Oct 2007
    Location
    UK
    Posts
    12
    Just tried both those settings and it still does the same thing.

  7. #7
    Join Date
    Mar 2006
    Location
    Ambient Design
    Posts
    3,839
    I'll look into it some more. The behaviour is different with my Intuos 4 - the pen and mouse are happy to work no matter how I switch between applications. I'll have to track down an Intuos 2 for testing.
    Just so I'm clear on the way you're switching applications, can you step me through what you're doing again?
    AndyRage's mantra for graphics engine code:
    "Sure - how hard can it be?"

  8. #8
    Join Date
    Oct 2007
    Location
    UK
    Posts
    12
    Yup, it happens when I use the tablet, then I click on another window e.g. Browser, change to using the windows mouse for a moment, then I enter AR again and the cursor goes awol. [edit] Still using the mouse that is, if I use the same input device I left AR with, everything is fine.

    Actually, the outline cursor appears to be stuck at the top of the AR window but vanishes completely when I move it around, it will then show up when over a tool palette. The other two cursor types will appear on the screen as normal, but none of them will paint on the canvas unless I use the tablet again.

    I can swap between tablet and mouse with no problems while inside AR and everything works fine, it only happens if I swap input devices outside of AR. Then it gets confused.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •