Page 1 of 9 123 ... LastLast
Results 1 to 10 of 81

Thread: ArtRage 3 and Linux

  1. #1

    ArtRage 3 and Linux


    I see we can expect AR3 very soon and it's so great news. However, I'd like to ask you *Rage guys and testers, can we linux users expect AR3 to work on linux machines too without some extensive hacking? AR2.5 was OK, so I hope you didn't forget us when working on AR3, did you? :-)

    Best wishes,


    EDIT 1: Installation instructions for AR3 can be found in a comment here (thanks to Aldrik; see his post).

    EDIT 2: Export issue solved: install corefonts with winetricks (thanks to azathothgr).
    Last edited by meho_r; 12-21-2009 at 02:02 AM.

  2. #2
    Join Date
    Mar 2006
    New Zealand
    We don't have a Linux native build of AR3 and unfortunately we don't have the resources to test it under emulation currently. There haven't been significant changes in the way the application and operating system interact however so it may well work fine. There will be a demo that you can try before purchase in case there are problems and we will make sure we publish any information in the forum that we are provided regarding how to get it going.
    ArtRage UI
    Ambient Design.

  3. #3
    OK, then, hope it'll do fine. Looking forward to try it. Thanks for the info

  4. #4
    Unfortunately, AR3 (Studio Pro Demo) doesn't work on Ubuntu 9.10 (64bit).

    1. Installation cannot be started. wine gives the following error:
    wine: Call from 0x7b845540 to unimplemented function msi.dll.MsiSetExternalUIRecord, aborting
    I tried to download msi.dll and even copy it from another computer, no avail.

    2. I copied installed AR3 from Windows and tried to run under Ubuntu. Program started, but I can't click on anything. The message that terminal gives is the following:
    fixme:win:EnumDisplayDevicesW ((null),0,0x32f4c4,0x00000000), stub!
    fixme:process:RegisterApplicationRestart (L"-rm",0)
    fixme:win:UpdateLayeredWindow (0x2002e,(nil),(nil),0x32f3cc,0x394,0x32f3c4,0x00000000,0x32f3bc,2): stub!
    So, if any Linux guru is around here, I would appreciate any hint. Meanwhile, I'll try AR3 on Mandriva 2010.0 (32bit) to see how it behaves there. And, I'll see if anyone from wineHQ can do something about this.

    EDIT: On Mandriva, installation gets stuck (wine Here's the terminal output:
    fixme:ole:CoCreateInstance no instance created for interface {ea1afb91-9e28-4b86-90e9-9e9f8a5eefaf} of class {56fdf344-fd6d-11d0-958a-006097c9a090}, hres is 0x80004002                                                                                       
    fixme:advapi:LookupAccountNameW (null) L"mehor" (nil) 0x33ed94 (nil) 0x33ed98 0x33ed8c - stub                                 
    fixme:advapi:LookupAccountNameW (null) L"mehor" 0x169570 0x33ed94 0x169d88 0x33ed98 0x33ed8c - stub                           
    fixme:msi:msi_unimplemented_action_stub MigrateFeatureStates -> 2 ignored L"Upgrade" table values                              
    err:richedit:ReadStyleSheet ReadStyleSheet: skipping optional destination
    err:richedit:ReadStyleSheet ReadStyleSheet: skipping optional destination
    fixme:exec:SHELL_execute flags ignored: 0x00000100
    fixme:msi:MsiGetFileSignatureInformationW L"D:\\Desktop\\install_artrage_studiopro_demo.exe" 00000001 0x33f484 (nil) (nil)
    fixme:advapi:LookupAccountNameW (null) L"mehor" (nil) 0x33ed94 (nil) 0x33ed98 0x33ed8c - stub
    fixme:advapi:LookupAccountNameW (null) L"mehor" 0x169d10 0x33ed94 0x16a528 0x33ed98 0x33ed8c - stub
    fixme:msi:ACTION_HandleStandardAction unhandled standard action L"SetODBCFolders"
    fixme:msi:msi_unimplemented_action_stub MigrateFeatureStates -> 2 ignored L"Upgrade" table values
    fixme:msi:msi_unimplemented_action_stub RemoveExistingProducts -> 2 ignored L"Upgrade" table values
    fixme:msi:msi_unimplemented_action_stub SelfUnregModules -> 4 ignored L"SelfReg" table values
    fixme:msi:msi_unimplemented_action_stub UnregisterExtensionInfo -> 1 ignored L"Extension" table values
    fixme:msi:msi_unimplemented_action_stub UnregisterProgIdInfo -> 1 ignored L"ProgId" table values
    fixme:msi:msi_unimplemented_action_stub RemoveShortcuts -> 3 ignored L"Shortcut" table values
    fixme:msi:msi_unimplemented_action_stub RemoveFolders -> 22 ignored L"CreateFolder" table values
    If I try to run it from the AR3 folder copied from Windows, it starts, but interface is totally messed up and absolutely unuseable
    Last edited by meho_r; 12-15-2009 at 03:57 PM.

  5. #5
    A little update:

    On Ubuntu 9.10, 64bit with wine2 (actually 1.1.34 from wineHQ PPA) I managed to run AR3 from the installation folder copied from Windows. There are two problems:

    1. Tooltips have a black rectangle arount them as well as Canvas positioner, Layers and other dialogs when they're expanded.
    2. AR3 seems pretty sluggish. May be my computer configuration (Athlon 64 3800+ 2.4GHz, 3GB RAM).
    3. I can save artwork in AR's original format, but export doesn't work. I get the error: "Generic failure. Not enough memory to perform action" (with 2GB RAM free).

    And, installation still stalls with the same message as I mentioned with Mandriva in my previous post.
    Last edited by meho_r; 12-16-2009 at 05:51 AM.

  6. #6
    Join Date
    Mar 2006
    New Zealand
    I'm certainly no expert but it looks like the current MSI installer version isn't supported by Wine (the 'fixme' directives seem to indicate unimplemented features). The application doesn't need to install anything outside its primary folders so technically installing on a Win istall and moving to Wine should work assuming the emulator supports all of the features used.

    If the floating dialogues are showing black rectangles that's probably due to Wine not supporting the transparent OS window functionality from 2k->Win7, we use Windows transparent windows for our floating panels.
    ArtRage UI
    Ambient Design.

  7. #7

    I haven't logged in this forum for quite some time, but well, there's the new release (congrats btw ) =D

    The demo appears to run in wine with a native gdiplus.dll .There's the black window borders, and no export, but there's also another thing. Every tablet stroke starts with a tiny bit at full pressure.

    If i click and hold the mouse button while moving the tablet around over the pad, the result is pretty much identical : a small blob at full pressure, and the rest of the stroke at normal pressure.

    I think the tablet registers as a mouseclick as well as a tablet event, because debugging shows normal pressure levels, but that's just guessing.

    It's a little slow for me too, but not unusable at all (pentium dual core, 2 gb ram, ubuntu karmic)

    I have high hopes for the transparent windows and exporting, wine gets better rapidly, but the pressure thing looks more weird ...

    EDIT : forgot to mention I tried it with all possible input device settings, precice tablet, win7 multitouch etc, but it's still the same
    Last edited by azathothgr; 12-16-2009 at 02:17 AM.

  8. #8
    Join Date
    Nov 2009

    Works almost fine on Ubuntu Jaunty 9.04 64bit

    Hi everyone.

    I just tested AR3 Studio Pro Demo on my Ubuntu Jaunty 9.04 64bit. Installation indeed didn't go well - I had to install AR3 on Virtual Machine (WinXP guest), and copy it to Wine folder in Ubuntu.

    All tools seem to work. I didn't test reference pictures or skencils, but ruler skencil works for example (missed that in AR2.5 on linux:-). Tablet (Wacom Intuos3) works as well. Interface toolboxes shows only when animation is ON in preferences, and they have black boxes underneath instead of shadows. But they're usable anyway.

    Wine version 1.1.34 with previously installed ArtRage2.5 Studio (therefore gdiplus.dll overwrited procedure applied).


  9. #9
    Here's the wine AppDB page :

    I haven't submitted any bugs about the pressure or the black windows yet, they may be already reported as similar issues in another application.. I'll try to do it later.

  10. #10
    Join Date
    Oct 2006
    Same issues on updated ubuntu karamic 9.10. wine install_artrage_studiopro_demo.exe wine: Call from 0x7b8453f0 to unimplemented function msi.dll.MsiSetExternalUIRecord, aborting

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts