Results 1 to 6 of 6

Thread: Slow response to controls when using tablet

  1. #1

    Slow response to controls when using tablet

    I'm experiencing an issue with ArtRage when trying to use the my tablet to control any of the interface controls.

    Basically, if I use the tablet to use any of the interface controls that involves the equivalent of a click-n-hold, I have to press with the tablet, hold, wait for the "loading" circle to draw and disappear, then I can move my pen. It takes about 4 seconds for the loading to stop.

    For example, if I want to re-size my tool, I press, wait 4 seconds, then I can move the pen to re-size. It also happens when moving a palette.

    If I attempt to move the pen before the "loading" circle disappears I'll end up performing a different function, such as panning the canvas or hiding the interface. Very annoying.

    I don't have the same problem when using the mouse and as a result I'll frequently drop my pen and use the mouse just to re-size the tool, then pick up the pen again. Very frustrating.

    I'm using the latest version of ArtRage (full version) and I'm running Vista 64. I don't experience any slowness when drawing on the canvas. I can confirm a spike in CPU usage when using the pen on a control, the equivalent of what I see when using the pen to draw.

  2. #2
    Join Date
    Mar 2006
    Location
    Switzerland - AG
    Gallery
    View images
    Posts
    1,180
    You say you havn't problem with mouse but some more fact would be interesting...

    -Canvas & tools size (0-500%?)
    -System specs (a bit more detailed)
    -Tablett type

    did you noticed any similar problems when you using the tablet in other applications?

    Greetz maror
    M.Siegrist

    Artrage 2.6 & Wacom Intuos 3 A5
    XP SP2

  3. #3
    Quote Originally Posted by maror View Post
    You say you haven't problem with mouse but some more fact would be interesting...
    Of course

    Canvas & tools size (0-500%?)
    My current canvas is only 767 x 1000 and zoom and tool size doesn't seem to have any impact.

    -System specs (a bit more detailed)
    CPU: Intel Core2 Duo @ 3.00 Ghz each
    RAM: 2.0 GB
    Video: 6600GT + 8800GT (3 monitors - I run ArtRage on my primary monitor driven by the 8800GT)
    OS: Vista 64bit

    Tablet type
    Wacom Intuos 3. I confine its use to the primary monitor.

    did you noticed any similar problems when you using the tablet in other applications?
    No. There is no delay when dragging a window or application palette. Drawing in other applications is ok, but drawing in ArtRage is also ok. It's just the ArtRage palettes that have I have a problem with.

    Please let me know if there are some other things I should try or other details I haven't thought of that might be significant.

  4. #4
    Join Date
    Oct 2008
    Location
    Belgium
    Gallery
    View images
    Posts
    259
    Geez, that's a nice config...

  5. #5
    Join Date
    Mar 2006
    Location
    Ambient Design
    Gallery
    View images
    Posts
    3,521
    Thanks for the information, some fairly formidable specs there!

    As you're using Windows Vista, let's check to see if it might relate to Microsoft Ink Services. To disable Ink Service use in ArtRage, try this. Create a file called 'no_ink.inf' and place it in ArtRage's resources subfolder. The file type isn't important, just the actual name.

    e.g. c:\program files(x86)\ambient design\artrage 2\resources\ <-- file goes here

    Then restart ArtRage, and see if you still get the same problem.

    If that doesn't help, try closing down any background applications you might be running, especially tablet helper utilities, then launch ArtRage to see if that might relate to the problem.
    Dave
    Resident Bug-Hunter
    Ambient Design

  6. #6
    Oh, that was too easy And it fixed the issues I described in... err... can't link to it.

    Thanks very much. I wish I knew this before completing my first painting

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •