PDA

View Full Version : Is this the area for questions about the Kindle Fire HDX AR app?



D Akey
06-13-2018, 04:21 PM
Android File Transfer is the app I'm using on my Mac desktop to interface, so I'm assuming a Kindle question would go here.

Q: Where are the library files stored on the Kindle (the library where you would add canvases and brushes)?

I'm wanting to add to the basic canvas selection where it would affect the tooth based on loading a jpeg.
But I would also like to add brush packs and such.

Just finding out the parameters or limitations of the Kindle Fire HD app.

Thanks.

Question 2:
What can I disable to get it to not lag using a basic stylus when drawing a simple line.

DaveRage
06-14-2018, 10:28 AM
The Android version library files for custom tool presets are stored in ArtRage/Resources/Tool Presets

If you don't see the name of the tool you're looking for in that folder, adding a new preset within the Android app will create one. For example: If you add a new oil brush preset, you'll see an 'Oil Brush' folder at that location.

You can copy presets from the desktop version and put them in the relevant folders to add new tool presets. This doesn't work for canvases however, as these are read from the app's internal resources.

The ability to do this is a side effect of the file system being exposed in Android, but we're considering ways for the future to allow import in mobile versions.

Regarding performance, can you email me at [email protected] with the tool settings and size you're using and what you're seeing? I'll see what I can do to help.

D Akey
06-14-2018, 07:30 PM
Yeah, thanks Dave. The Kindle is more mysterious and less accessible to see what's in system folders and that of apps. While I say it's Android, I'm not exactly sure that's what it's using as an OS. They probably have a proprietary code that does not allow casual access. Or maybe I need a different software to take a look. But anyway, I'm hoping you guys write a feature in on your end eventually to be able to grab a canvas from a jpeg and add brushes and so forth.

As to the tool settings I'll get all that sorted and email you. Just as a tip off, it's lots of tools lagging from pencil to pen to whatever. I thought it was working without lag before but I'll have to go through it carefully and send you details. What I was trying to do just for the heck of it was to use the stylus and print a sentence and some lines worked and some just didn't happen at all.

eg, if I made a capital A in a word, the A-Frame shape was there but the cross in the middle wouldn't show, depending on how fast I was printing. We'll see when I send you the particulars.

Thanks.

D Akey
06-15-2018, 09:55 AM
Hi Dave . I discovered the consistency of the line got better when I rotated the stylus 180 where I was touching the screen with the opposite side of the stylus tip. So I've concluded that the problem was with the cheap stylus I'm using and not with Art Rage. Thanks.

If I have a further problem I will email you the settings, but I think we're okay.

DaveRage
06-15-2018, 10:41 AM
That's interesting, haven't run into that before! Good to know so that I can consider that if anyone else has a similar problem. Glad to hear things have improved now though :)

D Akey
06-15-2018, 11:14 AM
To clarify, I kept the same tip pointed touching the screen but simply twisted it in place so the opposite side of the same tip was contacting the screen. I didn't use the opposite end of the stylus. But yeah. I was trying things out and couldn't figure out why it was working and then not, and then it was again. Just tripped over the solve on this one.

EDIT: There were two issues with the Pencil tool -- the lag time with the lines and the breaking contact where there were bits missing as when printing a sentence with my stylus on a canvas. The part I'm talking about being the worst was lines not being recorded usually when I changed directions as with an 'A' missing the middle horizontal line.

The lagging line not following the drawn line at speed improved substantially when I used your presets. I noticed that once I started looking carefully that I had the metallic setting at 4% which I didn't want but must have inadvertently checked it. Taking that off helped. But I think the stylus was the main problem.

DaveRage
06-18-2018, 10:11 AM
Thanks for the info! If you do run into further problems with performance, let me know via email and I'll take a look at it with you. I don't have a Kindle Fire here but I can take a look at similar tool settings on my devices for comparison.