PDA

View Full Version : [ Solved ] Save Pic with alpha channel?



inc
10-03-2017, 04:51 AM
Hi

is it possible to save all Layers in one PNG file including its Alpha channels?

Group Layers ?, save as Alpha PNG without the background Canvas?

i need this option .

-----------------------------------


Solution



1. Open the layers menu, merge all layers (temporarily!) and then choose to export that layer. It will be transparent automatically because it does not include the background.


merging all layer and export the layer into a png worked.

thanks for that info

markw
10-03-2017, 06:18 AM
Hello inc,

The PNG format dose support Alpha but dose not retain the individual Layers.
Best option here if individual layers are needed would be to export as a PSD file. However any information specific to ArtRage will be lost, e.g. paint depth, wetness etc...

To group Layers; in the Layers panel click the Group icon (looks like an open folder) to create a new Group and then drag into it the layers you want it to contain.

To not have the canvas background export; set the Canvas Opacity to 0% and effectively it won’t export.

inc
10-03-2017, 06:46 AM
it seem to be not working.
it is possible to save each layer as png incl. alpha (without background) all good.
but this is only for one layer.

Quote:
if individual layers are needed

No i need all of them combined in one picture and save without background.



if i have 7 layer, i wanna select all and save masked including alpha channel without layer 1 the canvas.
i can not find any solution. in my main paint program it's just simple possible.

and another strange behavior occurs now. i pressed once on a layer the [CTRL] key. this show me a line around the selected painted layer. but i have no idea how to switch off?

and then i always have this message:

93880

painting no longer possible :(

markw
10-03-2017, 09:06 AM
OK, try this;
In the finished painting open Canvas Settings.
Set Canvas Opacity to 0%.
Now go to File > Export Image File and in the dialog window that opens make sure you have PNG (Portable Network Graphic) selected as the export format.
Any areas of canvas that have no paint will be transparent in the resulting exported file.
If this isn’t happening for you then make sure you have no unexpected layer/s containing paint covering the whole canvas in the layer stack that may be preventing transparency.

To deselect; Make sure the offending layer is selected and go to; Edit > Deselect All or use key combo cmd+D or for Windows ctrl+D

inc
10-03-2017, 09:30 AM
OK, try this;
In the finished painting open Canvas Settings.
Set Canvas Opacity to 0%.
Now go to File > Export Image File and in the dialog window that opens make sure you have PNG (Portable Network Graphic) selected as the export format.
Any areas of canvas that have no paint will be transparent in the resulting exported file.


done = not working



If this isnít happening for you then make sure you have no unexpected layer/s containing paint covering the whole canvas in the layer stack that may be preventing transparency.

there are only a bunch of layers. nothing special but the transparent export does not work:

https://abload.de/img/opacity2rsep.png




To deselect; Make sure the offending layer is selected and go to; Edit > Deselect All or use key combo cmd+D or for Windows ctrl+D

thanks. that's it :D i guess i would never have found it

markw
10-03-2017, 10:25 AM
Oh…
That’s very disappointing to hear:(
The above steps work for me every time, no problems. I confess I’m out of ideas now. It could be a bug with your system+ArtRage, possibly?
Sadly I’m also out of internet access for today too:( Will look in again tomorrow and hopefully you will have found the problem.

inc
10-03-2017, 11:29 AM
i have no idea. i had in mind, it's just simple as usual. but it seems to be a problem.

maybe some one can test my portrait to save all layer into one alpha transparency png or tiff


so long, back to the painting :)

HannahRage
10-03-2017, 02:54 PM
Okay, first, your canvas is not transparent so that will be included in the image you export. Try either of these things:

1. Open the layers menu, merge all layers (temporarily!) and then choose to export that layer. It will be transparent automatically because it does not include the background.

2. Open the Canvas Settings (View > Canvas Settings) and set 'Opacity' to 0%. The background will change to a cell pattern. Close it and export your painting.

inc
10-04-2017, 06:43 AM
1. Open the layers menu, merge all layers (temporarily!) and then choose to export that layer. It will be transparent automatically because it does not include the background.


merging all layer and export the layer into a png worked.

thanks for that info

markw
10-04-2017, 07:32 AM
Well I’m back online for a bit and glad to see inc that you finally managed to get a viable PNG out:)
Though I’m still curious (I may have been a cat in a former life!) as to what in your painting was/is preventing a PNG export the normal way?
So if you might indulge me in some speculation…
Looking at your above screenshot of the Layers Panel again, what is the bottom highlighted layer that is set to 0% Opacity?
If you were using that as your "canvas/background" then setting just that to 0% won’t of helped as the actual ArtRage canvas would still be active at 100%. Both that layer, if acting as a "canvas/background" and the actual ArtRage canvas would need to be set to 0%.
To set the actual ArtRage canvas to 0% you would need to go to View > Canvas Settings and set it's Opacity to 0% there.
93887