PDA

View Full Version : Spanish letters in Text function



Ang
06-22-2015, 10:57 PM
Hi everybody,

Does anybody know how to write Spanish letters with the Text functionality? like ñ or accents: é, á etc.

I'm doing a picture book for children, in Spanish. I use Mac and Artrage 4.5.4

My Mac recognises these letters (as you can see above). But when I try them in Artrage, it doesn't work.

I'm quite new with Artrage...thanks in advance!

Angélica.

Someonesane
06-23-2015, 01:42 AM
How are you entering the letters? I've just copy/pasted those letters into my ArtRage 4 and they're showing up fine on a number of the fonts I've tested. It may be that the specific font you're using, doesn't come with those symbols.

Ang
06-23-2015, 02:27 AM
How are you entering the letters? I've just copy/pasted those letters into my ArtRage 4 and they're showing up fine on a number of the fonts I've tested. It may be that the specific font you're using, doesn't come with those symbols.


I'm entering, for example the ñ with alt+n+n.

I've used different fonts and didn't work with any (arial, bradley hand).

I've also tried the copy-paste option, and works halfway. It appears other symbols right before or after the spanish letter, then I erase those, but later on the words jumped to a different place (it sounds funny). I try to show you with a screen shot.
I've marked on purple those new symbols that appeared. Thanks for answering btw.

86840

markw
06-23-2015, 03:40 AM
Like for someonesane, copy/paste works of me too which dose get around the problem.
Also, unlike you, I'm not getting any strange additional symbols showing up and the text seems to be staying where I put it as well.
Which font are you using in AR?

Another possible workaround would be to do the text in another program perhaps.
I personally favour Pixelmator when I need to add text, (especially if there is a lot of it to do!) as It has more options/functions for working with text.
It also works fine with Spanish text and will accept the input just as you would normally type it elsewhere on the Mac.
They have a full trial version if you want to take it for a spin here: http://www.pixelmator.com/mac/try/

Someonesane
06-23-2015, 04:46 AM
Hmm... I'm unable to get the ñ symbol using alt+n+n in any of my programs, but that's likely a language settings thing on my computer, itself.

So if you wrote an entire sentence in a program like Notepad and copy/paste it into ArtRage, do you get those symbols, because I was able to copy and paste lines with those symbols from Notepad into ArtRage with no troubles. I was also able to add a number of unusual symbols into ArtRage by using my computers Character Map (the green text seen in my screen shot).

86841

markw
06-23-2015, 07:01 AM
Hola otra vez Angélica:)
Have been experimenting a bit and the following work flow works constantly for me here on my Mac:
1: Type out your text in TextEdit first and then copy it. (I used Helvetica size 14 but don't worry too much about font or size for now.)
2: In AR start a new text layer and paste in the text you just copied from TextEdit.
3: Highlight the text and while it's highlighted select your desired font and size in the Text Tool's settings panel or choose a preset if you've saved any before.
4: Arrange the text to taste as normal in AR.
I pasted the following in as just two lines and then re-arranged then in AR. (But I think my proof reading skills are somewhat lacking:o;))
86843

Ang
06-23-2015, 09:23 PM
Hola chicos!

Thank you guys for your answers.

Someonesane, my guess is that the problem has to do with my Mac settings. To start, the keyboard is german :(
But unfortunately my computer skills are so limited.

Mark, in your text happened also: the ñ of "mañanitas" jumped to the bottom to "aquí".
I've tried already what you suggest. And sometimes works better than other (just one or two letter jumping) but most of the times is worse.

I can live with the work around (correcting every time), but it would be much better if I could find a solution.

Thank you anyways guys!

Someonesane
06-24-2015, 02:12 AM
I figure this is probably some sort of bug/glitch that's related to a certain language package of ArtRage, since our versions seem to be fine with us inputting the characters (at least in terms of copy/pasting). It might be worth while to try the Support email (via the "Contact Us (https://forums.artrage.com/sendmessage.php)" link at the bottom of every forum page), to ensure you get a direct response from one of the ArtRage team. They're pretty good about finding and answering posts here, but that will guarantee a quicker reply, if you're in a crunch.

markw
06-24-2015, 06:11 AM
Well I think I spoke to soon in my last post!:o:(
After some more experimenting today, indeed some Spanish letters/characters are still getting moved around.
(But at least maybe my proof reading skills aren't as bad as I thought after all!;))
Have sent support a message about this bug.

Ang
06-24-2015, 11:59 PM
hey, thanks so much!

I'll keep working with the work around. And I'll send a message as well.