PDA

View Full Version : ArtRage 4 hangs when using stylus



Pamiiruq
02-04-2014, 03:06 PM
I'm using ArtRage 4.0.6 on Windows 8.1 with my Surface Pro 2. Everything works relatively perfectly except when I try to use the stylus to interact with the UI in any fashion, except in cases of picking a tool or color.

What happens is if I open a window like the preferences dialog, or tool settings, or even click "Check now" when asking whether to check for updates, if I use the stylus to do this, the application's CPU utilization will spike to close to 30% and the whole program will hang for several seconds. Eventually it will settle back to normal, but the action I made with the stylus may or may not be registered (not sure what criteria makes it register or not).

I took a screenshot during one of these occurrences. In it you can see the program using 29% CPU time and Windows indicates it is "Not responding".
79182
What I did for this screenshot was open the tool settings dialog and then use my stylus to attempt to drag it somewhere else on the screen. The only things I can do with the stylus without the program hanging up is, as I said, selecting a tool or color, or drawing on the canvas.

This is a relatively recent behavior, I believe. If I recall correctly, it only started up sometime within the past few versions.

I don't experience this behavior anywhere else within Windows, so I think it is a bug with ArtRage. I've tried uninstalling and then reinstalling it but it made no difference.

Has anyone else reported this behavior? Is there anything that I can do to fix it, or is it out of my hands and a bug in the program?

HannahRage
02-04-2014, 03:43 PM
Okay, this is probably a driver issue.

Troubleshooting Step One:

Go to
> Edit
> ArtRage Preferences
> Input Device
> Turn WinTab OFF and RealTime Stylus ON
> Restart ArtRage and see what happens

If this does not fix it, try turning off the Windows Ink option, You will find this in the driver set up under the Mapping tab, or the Calibration Tab, depending on driver version.

If this does not help, come back and tell us or drop us an email at support@artrage.com (if it does fix it, tell us that too!)

Pamiiruq
02-04-2014, 04:24 PM
Okay, this is probably a driver issue.

Troubleshooting Step One:

Go to
> Edit
> ArtRage Preferences
> Input Device
> Turn WinTab OFF and RealTime Stylus ON
> Restart ArtRage and see what happens

If this does not fix it, try turning off the Windows Ink option, You will find this in the driver set up under the Mapping tab, or the Calibration Tab, depending on driver version.

If this does not help, come back and tell us or drop us an email at [email] (if it does fix it, tell us that too!)

Disabling WinTab didn't fix it.

Also, I don't see any options relating to Windows Ink. I looked through the Windows pen settings and even the stylus properties in the Device Manager but there weren't any options like that to change. Am I missing something?

MattRage
02-04-2014, 05:09 PM
Sounds like a driver problem but it's interesting that turning off Wintab support didn't change it. Could you get in touch with us via support@artrage.com and we can go through some troubleshooting steps to see if we can find out why you're having this problem (we can't replicate it here).

Pamiiruq
02-05-2014, 10:24 AM
Sounds like a driver problem but it's interesting that turning off Wintab support didn't change it. Could you get in touch with us via [email] and we can go through some troubleshooting steps to see if we can find out why you're having this problem (we can't replicate it here).

I sent an email. It is from the same account I registered with. Thanks!

Pamiiruq
02-14-2014, 09:15 AM
Through some extended debugging on my end with Matt over email (they couldn't reproduce the issue on their end) we discovered that the hangs were related to my disabling "tab and hold to right-click" in Windows' Pen control panel:
79347

I had it disabled, and for whatever reason this caused my hangs to occur. I did not disable it for finger input so I presume that's why it worked perfectly fine.

I re-enabled the option and the problem went away. Matt said he'd make a note of it and investigate why this interacted with ArtRage as I described above. But at least I got it working again for the moment! :)

Thanks for your help and patience!

MattRage
02-14-2014, 10:25 AM
I think we went through pretty much every troubleshooting permutation I know of before we hit on this. For anyone reading this who has similar problems with the sliders and other elements in floating panels 'hitching' during use this is an important option to know about.

However - In one of our test cases (Win7, external Wacom tablet) we were able to replicate the hitching problem only with the Tap and Hold - Right Click option enabled, turning it off was required to solve the problem. In other words the exact opposite of the solution that worked here.

There's something odd going on in the depths of Windows tablet handling that's causing the hitching and we're going to look in to it to see if we can find out why it's happening in the floating panels specifically.

SnakE
08-23-2015, 11:26 PM
Hi, FYI -- I was having exactly the same issue today in Windows 10 Home, Lenovo ThinkPad 10, ArtRage 4.5.4-64. And exactly the same fix helped me -- I had to enable the press and hold for right clicking here:

<Win-X> > Control Panel > Pen and Touch > Press and hold > Settings > Enable press and hold for right-clicking

Either the problem in ArtRage is still not fixed or Win10 resurrected it somehow. My tablet is upgraded to the latest version of everything.

SnakE
05-26-2016, 12:54 PM
So it's May 2016, ArtRage 4.5.10 -- and the issue is still there. Any plans or progress?

I tried to disable Press and Hold to address the stroke delay: my strokes start a few millimeters past the point where I actually touch the screen. It's not the "lag" that the FAQ is talking about, it's an opposite thing. I couldn't find any information on that either.

May be related: if I enable Press and Hold so that nothing hangs; grab e.g. the Canvas Positioner and move it around the screen it starts moving slower and slower, reducing to a couple of frames per second after moving it for 10 seconds. After 20 seconds the frame rate drops to below 1 FPS. Releasing the pen restores the frame rate. The same happens when I e.g. zoom using the Positioner. It zooms fine the first few seconds then starts to quickly slow down and becomes unusable.

MattRage
05-26-2016, 01:46 PM
This appears to be a driver issue, it's not something we can replicate locally with the press and hold / right click toggle adjusted. It might pay to check that ArtRage is set to Use RTS only and that you do not have any stray tablet drivers installed. There's definitely something external causing issues for a small number of people (actually, I think this is the first time we've heard of it happening in some time) so starting with a clean driver setup is probably the best first step. If that does not help, drop a mail to support@artrage.com and we'll see if we can work through and solve it for you.

SnakE
06-06-2016, 10:27 AM
Thank you for answering Matt.

First I want to make sure that you know what my system is. I'm using ArtRage 4.5.10-64 on a Lenovo ThinkPad 10 running Windows 10. These are equipped with limited Wacom hardware controlled by Wacom Feel driver, us.wacom.com/en/feeldriver/. I've just upgraded to the latest driver version 7.3.2-12 which made no difference at all. The symptoms are the same. Moving tool windows slows to a crawl in few seconds when tap-and-hold is enabled, and cannot be moved at all when tap-and-hold is disabled. Buttons in tool windows (like Don't Save in exit confirmation) cannot be tapped when tap-and-hold is disabled.

Now the main issue why I even started experimenting with disabling Tap-and-hold. It's a delay between pen touching the screen and line starting to appear, in that order. I don't know if it's related. To illustrate here are two drawings, one in SAI and one in ArtRage, done on the same tablet, same driver and everything else, within few minutes between the drawings.



SAI
ArtRage


89948
89947



In both cases I tried to start my vertical lines at exactly the horizontal line. SAI responded flawlessly while ArtRage hesitated for a moment every time, resulting in a significant gap. This makes it hard to put little quick details and breaks my confidence in my stroke.

Please let me know if this clarifies something or if I should really move this discussion into an email to support.

MattRage
06-14-2016, 01:33 PM
The Wacom Feel driver is generally used where a device does not do Wintab natively (being an older standard and not the MS suggested standard for screen input devices) and as a generic driver it may not work properly with some devices. In cases where apps only support Wintab (which is fairly common, as not many apps have implemented the current RTS standard) those apps may work fine, but if the Wacom Feel driver is causing collisions between Wintab and RTS, which has been known to happen, it may cause problems for apps that support both.

The first thing to do is make sure that you have tried turning off Realtime Stylus and making sure Wintab is turned on in the Preferences panel's Input section. Restart ArtRage and see if that helps (apologies if you have already done this). There may still be a problem with the RTS input however even in this case.

Looking at Lenovo's site there is a Wintab driver specifically for the device you are using: http://support.lenovo.com/en/downloads/ds041537

Try that driver instead of the Feel driver. Wacom provides their generic drivers to hardware vendors so that any required changes can be made specifically for hardware variations and that may also solve the problem. If it doesn't, get in touch with us at support@artrage.com and we can start doing some specific troubleshooting.

SnakE
06-17-2016, 11:51 AM
Thank you for your help Matt! Installing the official Lenovo Wintab driver have fixed my issue. My exact driver link was different but I was able to find it using Lenovo's driver search. Now ArtRage works OK in Realtime mode (no more slowing down) and works flawlessly in Wintab mode. I hope this forum thread will help others with a similar problem.

One more question, what the Precise Tablet option does? Should I check it?

HannahRage
06-17-2016, 03:38 PM
Precise Tablet is a high resolution input mode that creates more precise strokes - so yes, it's good to have. It can cause problems if your tablet doesn't support it properly, so if you see any issues, just turn it off again.