View Full Version : Exchanging images with photoshop

04-18-2006, 12:45 AM
I am having troubles when I try to import images from photoshop. Can you help me? I seems that the option at file>import images is not working properly.
Thank you! :(

04-18-2006, 03:46 AM
What do you mean, exactly, when you say that it's not working properly? What happens when you try to import a Photoshop PSD? Are you getting any error messages?

I just tried importing a small PSD into ArtRage and then again a slightly larger, multi-layered file. Both worked flawlessly. I have XP SP2, ArtRage (full) 2.05, and Photoshop CS2. How about you?

- Gita

04-18-2006, 03:58 AM

I just bought a ArtRage, which I know for sure is 2.0 (hope they sold me the 2.05...). I use the photoshop 7.0.
The message is an error one, saying it is not an artrage file.

04-18-2006, 12:21 PM
Hi Oswald!

We did fix a few bugs relating to importing Photoshop files in ArtRage 2.0 when we upgraded to 2.05. You can check which version you have in the Help > About menu item. If you don't have the latest you can upgrade for free by downloading the patch from www.ambientdesign.com/artragedown.html.

Are you using Windows or OSX, and which version of the operating system are you on? ( e.g. Windows XP, OSX 10.3.8 )

If you have a photoshop file which won't import into 2.05, you could email it to me at support@ambientdesign.com and I can have a look here to find out what the problem is. If there's a problem with our input we should be able to fix it from there.

One thing, if you have an empty layer in your PSD, or an empty adjustment layer, we have noticed some problems with these which will be fixed in our next update which will be out super soon now!

04-21-2006, 07:26 AM
The trouble was with empty layers. Without it, works ok! Thank you!

04-21-2006, 12:41 PM
Glad to hear that helped! Keep an eye out for our update soon which should sort that out for you :)

07-27-2006, 06:58 AM
Hi. I'm on a mac OS X, I have AR 2.11. When I try to import a .psd, I get one of a couple of error messages. One says "A function call has been made to a function that has not been implemented yet." Continues that the file or format isn't supported by AR. The other says simply the last part (not supported). I tried removing an invisible layer. No go. I tried merging all layers. Nope. I tried flattening the layers. THEN I could open it. Is there something about transparence?
Is there something I'm not doing right?

07-27-2006, 07:27 AM
I got PS7 and the latest version of ArtRage,

If i export PS files out of ArtRage, they open up fine in PS7.oh and im using Windows 2000.......

07-27-2006, 08:37 AM
Check that your Photoshop document is an RGB 8 bit-per-channel document.
Also, if you're using Photoshop CS2, you'll need to save in 'compatibility mode'

We dont yet support CMYK, indexed colour, or layered 16 bit-per-channel PSDs

07-27-2006, 08:52 AM
Ah! Will try that.