View Full Version : Artifacts when drawing on my tabletPC

08-02-2006, 09:33 AM
I have a problem with some strange artifacts that appears on a random when drawing on my tabletPC. I just wonder if anyone else have this problem and if it exist a solution to the problem.

08-02-2006, 09:36 AM
I forgot my system specs.
Toshiba Tecra M4 TabletPC with the latest wacom pen tablet driver.

08-02-2006, 07:18 PM
hmmm... are your sure it is correct to use wacom tablet drivers with this tabletPc :?:

maybe there is the problem...


08-03-2006, 10:43 AM
Yes, it is good to use the Wacom driver. The built-in drivers from MS are limited, and to get the full usefulness of the tablet/pen capabilites, you have to load the Wacom drivers, which are gotten through the Wacom website. The TabletPC manufacturers do not install or provide them.


D Akey
08-03-2006, 12:50 PM
Hi drzeller,

Does it ever happen when you use your mouse?

If not, then perhaps you could try changing your pen settings in tablet preferences to mouse mode? Or with the PC it may be inside AR under Edit (I have a Mac so I don't know what's on a PC version).

I vaguely recall it happening to me once when I first got the program. But it corrected itself, or I stopped doing what it was that made it happen.

May have been before I got the full version. Sorry I'm not recalling exactly cause it stopped doing it after that one session.

Are you using the full version of Art Rage 2?

Good luck.

D Akey
08-03-2006, 12:52 PM
Oops. That post was meant for MiSt who was having the difficulty.

08-04-2006, 02:35 AM
Thanks for all the tips, even if I tested everything and it still occurs.

Wacom drivers are needed and OK to use because it's wacom that's do the technology behind the tabletPC.
I've tried some different settings of the sensitivity and it helps a little but it doesn't solve the issue.

Mousemode in Artrage doesn't help.

Here's a link to a review of Artrage and this guy have the same problem.

Any one else?

08-04-2006, 06:54 AM
I forgot to say that I have the full version of Artrage 2.11

I've also used Sketchbook pro, photoshop and painter without any problems, so it seems like it's artrage that have some issues with pressure sensitivity on tabletPC's. Maybe I should try a normal wacom tablet and see if the problem still occurs.

08-04-2006, 02:07 PM
Hi Mist,

Thanks for the information. Regarding the review byat cartoonmonkey that you linked to, I believe Chad emailed me at a later date to tell me that upon updating to a more recent version of ArtRage, he found that the artifacts no longer occured. However, this may have been due to a factor we're not aware of. It's interesting ( although again, a bit mysterious! ) to see that D Akey also had the situation correct itself.

I'll load the latest pen tablet on our test tablet here when I get the chance, and see if I can reproduce this behaviour. If I'm able to, we'll be able to test it further here, add it to our buglist and see what we can do about it.

D Akey
08-04-2006, 04:58 PM
Hi Dave,

If Chad stopped having the problem after an upgrade/update, and he e-mailed you as much, he probably should include it in the review.

I just read the review earlier today and, though I didn't read it all that carefully, I didn't see any addendum mentioning it was fixed with a later version.

Perhaps you want to wait until MiSt gets it sorted out as a confirmation.

Maybe it's just that ArtRage mellows to an ArtFixation with age. :P

08-04-2006, 10:38 PM
DaveRage: Thanks! I hope you find a solution, It's quite annoying. Otherwise I think Artrage is a wonderful piece of software.

08-05-2006, 05:35 AM
Seems like I found a solution, I uninstalled the wacom driver and it seems to work now. I still think it's a problem with artrage because all of the other apps works fine even when I have the wacom driver installed.

D Akey
08-05-2006, 01:07 PM
Are the other programs working with that second driver? In other words, do you have to sacrifice those other applications for ArtRage and visa versa?
That wouldn't be good.

08-05-2006, 10:33 PM
No, I don't have to scrifice the other apps they work just fine now aswell. But I don't have any chance to setup my wacom tablet because I don't have the drivers installed, so I can't set the pressure sensititvity and things like that.( I have to live with the default settings.)
It's kind of strange because before I installed the driver I didn't have any pressure sensitivity at all, I needed the driver to get it, but now when I uninstalled the driver it still is pressure sensitive.

08-06-2006, 12:18 AM
This probably won't be of help, however I had a similar problem with a different application and found that it was the scratch drive I had chosen.
It seems that the second internal drive was not as fast as my primary and caused lag and artifacts. Changing the drive usage cured that problem.

08-08-2006, 04:24 PM
I've been experimenting with the Wacom Pen Tablet driver 4.95-6 on out TabletPC here but so far I've been unable to detect a difference between having the Wacom driver installed and not unfortunately.

Of course that certainly doesn't mean there's no problem, your example image did show some clear oddities and the Tablet I'm using is older. We do plan to rework the tablet handling for a future update. I've made a note about some potential differences in the look between strokes on the tablet and my PC test system here as well.

It's odd that you didn't have pressure sensitivity by default, but I'm really glad to hear that that's working for you now.

08-12-2006, 11:18 PM
DaveRage: I think it's quite usual that tabletpc's is without pressure sensitivity from the factory, but I don't know. I only know that this is the case for Toshiba's tabletpc's.

I'm very happy with your effort on this issue and I hope you can find a solution some day. For now the problem is solved for me and I'm using Artrage with enjoyment. Thanks! :D