Results 1 to 5 of 5

Thread: Artrage version 4 on Linux Ubuntu

  1. #1
    Join Date
    Oct 2012
    Gallery
    View images
    Posts
    6

    Artrage version 4 on Linux Ubuntu

    Edit 1:
    Getting close'ish. Managed to get the installer running, but it doesn't actually install. When running wine from the terminal it was complaining about some ola error, so I googled and found this. Method, run: winetricks vcrun6 native_oleaut32

    I also tried running the msi after this command and again, the installer shows, but it then complains about not being able to find a data1.cab file. Maybe something to do with the fact that the installer was made for Win8, maybe I shouldn't be using vcrun6?

    ________________________________________-

    All,
    Up to now I have been using Artrage 3.x through Wine on Ubuntu. I bought AR4 and found that the workarounds no longer work around. Links:
    Links can be found on the wine website and in a sticky at the top of this forum. I was not allowed to post links!

    Does anyone have any updated information? Has anyone managed to get it working?

    Thanks,
    Phil
    Last edited by philwinder; 06-07-2013 at 08:34 PM.

  2. #2
    Join Date
    Oct 2012
    Gallery
    View images
    Posts
    6
    Sorry guys, I spent a good 3 hours on this and couldn't get any further. It seems to begin to install straight away using wine 1.5.31, but locks up during the install. Some files are written to the Resources folder, but thats it. There are no errors, but a few warnings from wine. See below.

    There are three files created in the install folder in the application data/Ambient Design/Artrage ..../install: holder0.aiph, install_artrage_4.aiui and install_artrage_4.msi. I have no idea what the aiui and aiph files are, and the msiexec installer complains about not being able to find a data1.cab file.

    I hope this information might spur someone better than me to get it working. I really hate having to use my Windows work's laptop to use artrage! Back to version 3 I go.

    Thanks,
    Phil

    fixme:storage:create_storagefile Storage share mode not implemented.
    fixme:advapi:LsaOpenPolicy ((null),0xcfe310,0x00000001,0xcfe328) stub
    fixme:advapi:LsaClose (0xcafe) stub
    fixme:advapi:LsaOpenPolicy ((null),0xcfe310,0x00000001,0xcfe328) stub
    fixme:advapi:LsaClose (0xcafe) stub
    fixme:advapi:LsaOpenPolicy ((null),0xcfe310,0x00000001,0xcfe328) stub
    fixme:advapi:LsaClose (0xcafe) stub
    fixme:advapi:LsaOpenPolicy ((null),0xcfe310,0x00000001,0xcfe328) stub
    fixme:advapi:LsaClose (0xcafe) stub
    fixme:advapi:LsaOpenPolicy ((null),0xcfe310,0x00000001,0xcfe328) stub
    fixme:advapi:LsaClose (0xcafe) stub
    fixme:advapi:LsaOpenPolicy ((null),0xcfe310,0x00000001,0xcfe328) stub
    fixme:advapi:LsaClose (0xcafe) stub
    fixme:shell:SHGetKnownFolderPath flags 0x00004400 not supported
    fixme:shell:SHGetKnownFolderPath flags 0x00004400 not supported
    fixme:shell:SHGetKnownFolderPath flags 0x00004400 not supported
    fixme:ntdll:server_ioctl_file Unsupported ioctl 110008 (device=11 access=0 func=2 method=0)

  3. #3
    Join Date
    Mar 2006
    Location
    New Zealand
    Gallery
    View images
    Posts
    3,151
    SHGetKnownFolderPath appears to have been a problem for some time in Wine, although in theory it was fixed in an earlier version so I'm not sure why it's not working now. My understanding of how Wine works is extremely limited but from what we can see that's the only thing really causing a problem and if they were to reimplement it the installer would probably work.

    Unfortunately we're not able to switch installers at this time, so the only real solution would be to install ArtRage on a Windows machine and copy the folder across to your Wine based Linux machine, which I know isn't always convenient.

    We're going to keep looking in to it to see if we can either get the SHGetKnownFolderPath function reimplemented or work out an alternative in our current installer system.
    Matt
    ArtRage UI
    Ambient Design.

  4. #4
    Join Date
    Oct 2012
    Gallery
    View images
    Posts
    6
    Matt,
    Thanks for this message and the email. Indeed, copying over the Artrage 4 program files folder and running with wine does (almost) work. There are a couple if issues (windows popping up behind main window, wine errors, etc.) but I think these are probably more wine issues. I'll look into them and get back.

    Thanks,
    Phil

  5. #5
    Join Date
    Aug 2009
    Gallery
    View images
    Posts
    13
    I've been having the same exact issue... been using ArtRage for years on Wine, but haven't been able to use 4. It was a major bummer.

    This workaround actually worked for me -- copying the files over from a VM allowed it to run. However, it is incredibly and unusably slow... are you having any performance issues? No doubt a wine issue (using 1.7 now), but ArtRage 3.5 was never this slow on wine.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •