PDA

View Full Version : Issues with fill tool



BobP
02-26-2012, 07:19 PM
I have recently started to use the latest version of art rage for ipad2 and have come across the following behaviour with the filling tool: if the line defining the boundary of the shapes is too thin the filling tool does not see the boundary and consequently does not fill properly.

For example, using the pen set as an artists pen (line size 2%) the fill does not work as it should.By increasing ,the line size to 4%,the problem is eliminated However,when using some of the pencil tool presets, the size cannot be increased enough.

BobP
02-26-2012, 07:46 PM
Sorry,I should have said technical pen not artists pen. Also increasing the pen size is not foolproof: the fill can progress OK then the fill action fills all the remainingunfilled, area irrespective of the boundaries

bobP

DaveRage
02-27-2012, 03:05 AM
If your fill is overlapping the boundaries of an area which have been fully encircled by another tool, this would generally indicate that the 'spread' setting for the fill tool has been set too high which would be expected behavior.

The fill tool isn't aware of the colour of the area intended, it just looks at the difference between the colour you clicked on and each pixel it tries to spread to. This means that thin lines arent as good at constraining fill areas as thicker lines when using high fill spread values ( thin lines don't tend to be pure colour due to antialiasing to soften the edges )

The spread setting indicates the range of colours which the fill tool sees as valid parts of its fill area. Decreasing it by opening the settings panel and lowering the spread value constrains the fill tool to a more narrow range.

BobP
02-28-2012, 08:54 PM
Dave,

thanks for your help.

bob